libarchive: Reduce dependencies by disabling them using configure args
authorJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Sat, 23 Aug 2014 13:49:52 +0000 (15:49 +0200)
committerJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Sat, 23 Aug 2014 13:53:12 +0000 (15:53 +0200)
In order to reduce the dependencies, this patch disables following features:
 * Extended Attributes
 * ACL support
 * bzip2 through bz2lib
 * lzop through liblzo2
 * crypto support from Nettle
 * xar through libxml2

Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
libs/libarchive/Makefile

index b673111bc651519342e3b9deab799850e398c2cc..1693cd01538210456b28f4c555211ec0d06be037 100644 (file)
@@ -30,7 +30,7 @@ endef
 
 define Package/libarchive
   $(call Package/libarchive/Default)
-  DEPENDS:=+libxml2 +libopenssl +zlib +libacl +libattr +libbz2 +liblzo +libnettle
+  DEPENDS:=+libopenssl +zlib
   TITLE:=Multi-format archive and compression library
 endef
 
@@ -38,6 +38,14 @@ define Package/libarchive/description
  Multi-format archive and compression library.
 endef
 
+CONFIGURE_ARGS += \
+       --disable-acl \
+       --disable-xattr \
+       --without-bz2lib \
+       --without-lzo2 \
+       --without-nettle \
+       --without-xml2
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/