dovecot: include nls.mk for iconv support
authorSebastian Kemper <sebastian_ml@gmx.net>
Fri, 13 Jul 2018 20:37:18 +0000 (22:37 +0200)
committerSebastian Kemper <sebastian_ml@gmx.net>
Fri, 13 Jul 2018 20:44:19 +0000 (22:44 +0200)
libmariadb 10.2 needs to be linked in together with iconv, hence include
nls.mk.

dovecot will use iconv (if it can find it) also for its own character
conversion needs, so add a general depend as well.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
mail/dovecot/Makefile

index 4aa68b8039d7adab21b974d33de9c9cd8157ccdd..7bd5bef5b960078575b2eedf41ae86ebf05d5736 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dovecot
 PKG_VERSION:=2.3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.dovecot.org/releases/2.3
@@ -31,11 +31,14 @@ PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
+# iconv is needed when compiling with MySQL support. iconv will also be used by
+# dovecot itself.
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/dovecot
   SECTION:=mail
   CATEGORY:=Mail
-  DEPENDS:=+DOVECOT_GSSAPI:krb5-libs +DOVECOT_LDAP:libopenldap +DOVECOT_MYSQL:libmysqlclient +DOVECOT_PGSQL:libpq +DOVECOT_SQLITE:libsqlite3 +libopenssl +librt +zlib +libbz2 +libcap +DOVECOT_ICU:icu
+  DEPENDS:=+DOVECOT_GSSAPI:krb5-libs +DOVECOT_LDAP:libopenldap +DOVECOT_MYSQL:libmysqlclient +DOVECOT_PGSQL:libpq +DOVECOT_SQLITE:libsqlite3 +libopenssl +librt +zlib +libbz2 +libcap +DOVECOT_ICU:icu $(ICONV_DEPENDS)
   TITLE:=An IMAP and POP3 daemon
   URL:=https://www.dovecot.org/
   USERID:=dovecot=59:dovecot=59