ccache: Speed up building.
authorMarkus Gothe <markus.gothe@genexis.eu>
Wed, 12 Jan 2022 16:13:43 +0000 (17:13 +0100)
committerJohn Crispin <john@phrozen.org>
Thu, 12 Dec 2024 10:01:56 +0000 (11:01 +0100)
- Disable compression for ccache's cached files.
- Disable the hashing of the CWD inside debug information. This
  increases the cache hits drastically.

Signed-off-by: Markus Gothe <markus.gothe@genexis.eu>
rules.mk

index 54df407fca4b952ccf7886299c2685cb8fe13ba3..9db7c72fa492ebd7539ebe1f3198c2ee955e86bb 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -342,6 +342,8 @@ ifneq ($(CONFIG_CCACHE),)
   TARGET_CXX:= ccache $(TARGET_CXX)
   HOSTCC:= ccache $(HOSTCC)
   HOSTCXX:= ccache $(HOSTCXX)
+  export CCACHE_NOHASHDIR:=true
+  export CCACHE_NOCOMPRESS:=true
   export CCACHE_BASEDIR:=$(TOPDIR)
   export CCACHE_DIR:=$(if $(call qstrip,$(CONFIG_CCACHE_DIR)),$(call qstrip,$(CONFIG_CCACHE_DIR)),$(TOPDIR)/.ccache)
   export CCACHE_COMPILERCHECK:=%compiler% -dumpmachine; %compiler% -dumpversion