vblade: change config to read-only
authorFlorian Fainelli <florian@openwrt.org>
Sat, 19 Feb 2011 12:44:05 +0000 (12:44 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 19 Feb 2011 12:44:05 +0000 (12:44 +0000)
This patch changes the default vbladed config to read-only. It
circumvents data corruption in case of the accidental simultaneous rw
mount.

Signed-off-by: Paul Geraedts <p.f.j.geraedts@gmail.com>
SVN-Revision: 25579

net/vblade/Makefile
net/vblade/files/vblade.config
net/vblade/files/vblade.init

index 9a8afc00dea8ca36008a116ec9de12afb275595f..ca5f371e90fa695b6af14199a2b2de472a503ee7 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vblade
 PKG_VERSION:=20
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/aoetools/vblade
index 1f35c07c079d634b11a0db58f5975c24943ba7ef..455988ac0686f26503bcf87a90ffc1faddc6daa4 100644 (file)
@@ -3,10 +3,12 @@
 #      option slot             '1'
 #      option netif            'eth0'
 #      option device           '/dev/sda'
+#      option options          '-r'
 #
 #config vblade
 #      option shelf            '1'
 #      option slot             '2'
 #      option netif            'eth0'
 #      option device           '/dev/sdb'
+#      option options          '-r'
 #
index bf59d582d14bc4e8fb1a616c54c970173a42d819..afed46bee804a6a1c696f18b5f57b0d767b9f1ac 100644 (file)
@@ -9,7 +9,8 @@ start_service() {
        config_get slot "$section" slot
        config_get netif "$section" netif
        config_get device "$section" device
-       vbladed $shelf $slot $netif $device
+       config_get options "$section" options
+       vbladed $options $shelf $slot $netif $device
 }
 
 start() {