vsftpd: update init script to use procd
authorMohd Husaam Mehdi <husaam.mehdi@iopsys.eu>
Wed, 27 Mar 2024 16:05:14 +0000 (21:35 +0530)
committerFlorian Eckert <Eckert.Florian@googlemail.com>
Wed, 8 Jan 2025 13:40:44 +0000 (14:40 +0100)
update init script to use procd

Signed-off-by: Mohd Husaam Mehdi <husaam.mehdi@iopsys.eu>
net/vsftpd/Makefile
net/vsftpd/files/vsftpd.conf
net/vsftpd/files/vsftpd.init

index 277e86c577497e746b121427de8744556e1633d4..34f26e3e28627016a96ca559726b156640bf7696 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vsftpd
 PKG_VERSION:=3.0.5
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://security.appspot.com/downloads/
index e06ac35431af47a2e3e3083af01c4eb9af390a9d..1c63451741510b6a6e7d1064f07e6a2cdad7f951 100644 (file)
@@ -1,4 +1,4 @@
-background=YES
+background=NO
 listen=YES
 anonymous_enable=NO
 local_enable=YES
index ad3e23da5fc3a1ac8e07b660e19d0926b42e9096..a1673ee43f8e24b80b17b80a7ea5ce6259aa195f 100644 (file)
@@ -2,12 +2,12 @@
 # Copyright (C) 2006-2011 OpenWrt.org
 
 START=50
+USE_PROCD=1
+BIN=vsftpd
 
-start() {
-       mkdir -m 0755 -p /var/run/vsftpd
-       service_start /usr/sbin/vsftpd
-}
-
-stop() {
-       service_stop /usr/sbin/vsftpd
+start_service() {
+       procd_open_instance
+       procd_set_param command $BIN
+       procd_set_param respawn
+       procd_close_instance
 }