gst1-plugins-ugly: Disable debug + other fixes
authorRosen Penev <rosenp@gmail.com>
Mon, 18 Mar 2019 02:52:16 +0000 (19:52 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 18 Mar 2019 04:12:43 +0000 (21:12 -0700)
Added PKG_BUILD_PARALLEL for faster compilation.

Removed old rpath hack that is no longer necessary.

Removed and replaced two patches with configure arguments.

Added PIC as is standard with these.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
multimedia/gst1-plugins-ugly/Makefile
multimedia/gst1-plugins-ugly/patches/002-no-tests.patch [deleted file]
multimedia/gst1-plugins-ugly/patches/003-no-docs.patch [deleted file]

index bb8119ff06700822e9a7c4c0e1356cbc89f6cab3..b1dbf85fa3db337bbe05bc4e452bb0df6756c4f7 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst1-plugins-ugly
 PKG_VERSION:=1.15.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
                Ted Hess <thess@kitschensync.net>
@@ -27,6 +27,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_gst1-mod-mpeg2dec \
 
 PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -96,6 +97,12 @@ GST_VERSION:=1.0
 CONFIGURE_ARGS += \
        --disable-debug \
        --disable-examples \
+       --disable-fatal-warnings \
+       --disable-glib-asserts \
+       --disable-gobject-cast-checks \
+       --disable-gtk-doc-html \
+       --disable-valgrind \
+       --disable-rpath \
        \
        --disable-a52dec \
        --disable-amrnb \
@@ -117,13 +124,7 @@ CONFIGURE_ARGS += \
        \
        --without-libiconv-prefix \
        --without-libintl-prefix \
-
-TARGET_CFLAGS += -Wno-format-nonliteral
-
-EXTRA_LDFLAGS+= \
-       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
-       $(if $(ICONV_FULL),-liconv) \
-
+       --with-pic
 
 define Package/gst1-plugins-ugly/install
        /bin/true
diff --git a/multimedia/gst1-plugins-ugly/patches/002-no-tests.patch b/multimedia/gst1-plugins-ugly/patches/002-no-tests.patch
deleted file mode 100644 (file)
index 79bd86f..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,7 +1,7 @@
- DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
- SUBDIRS = \
--      gst-libs gst ext docs m4 tests common pkgconfig
-+      gst-libs gst ext docs m4 common pkgconfig
-       
- EXTRA_DIST = \
-       depcomp \
---- a/configure.ac
-+++ b/configure.ac
-@@ -423,9 +423,6 @@ ext/x264/Makefile
- docs/Makefile
- docs/plugins/Makefile
- docs/version.entities
--tests/Makefile
--tests/check/Makefile
--tests/files/Makefile
- m4/Makefile
- pkgconfig/Makefile
- pkgconfig/gstreamer-plugins-ugly-uninstalled.pc
diff --git a/multimedia/gst1-plugins-ugly/patches/003-no-docs.patch b/multimedia/gst1-plugins-ugly/patches/003-no-docs.patch
deleted file mode 100644 (file)
index 4c29c79..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,7 +1,7 @@
- DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
- SUBDIRS = \
--      gst-libs gst ext docs m4 common pkgconfig
-+      gst-libs gst ext m4 common pkgconfig
-       
- EXTRA_DIST = \
-       depcomp \
---- a/configure.ac
-+++ b/configure.ac
-@@ -420,9 +420,6 @@ ext/dvdread/Makefile
- ext/mpeg2dec/Makefile
- ext/sidplay/Makefile
- ext/x264/Makefile
--docs/Makefile
--docs/plugins/Makefile
--docs/version.entities
- m4/Makefile
- pkgconfig/Makefile
- pkgconfig/gstreamer-plugins-ugly-uninstalled.pc