libgd: fix version in generated pkg-config .pc file
authorMichael Heimpold <mhei@heimpold.de>
Tue, 3 Dec 2019 20:35:43 +0000 (21:35 +0100)
committerMichael Heimpold <mhei@heimpold.de>
Tue, 3 Dec 2019 20:39:33 +0000 (21:39 +0100)
With the previous change to cmake, the generated pkg-config .pc
file does not contain the library version anymore. This breaks
programs which checks for a specific version, e.g. upcoming PHP 7.4.

The version is not filled because of a variable misnaming,
which was not covered by the imported upstream patch.

To not mangle the upstream patch, add an additional patch to
fix things up.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
libs/libgd/Makefile
libs/libgd/patches/300-gdlib.pc-cmake.patch [new file with mode: 0644]

index e298e9fc4bd3f0aed2a41aed47ec63f5d7af1c52..6dfe81df41fa61a62863a536b4ad85f65ab33d59 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libgd
 PKG_VERSION:=2.2.5
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/$(PKG_NAME)/$(PKG_NAME)/releases/download/gd-$(PKG_VERSION)/
diff --git a/libs/libgd/patches/300-gdlib.pc-cmake.patch b/libs/libgd/patches/300-gdlib.pc-cmake.patch
new file mode 100644 (file)
index 0000000..fe1a726
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/config/gdlib.pc.cmake
++++ b/config/gdlib.pc.cmake
+@@ -5,7 +5,7 @@ includedir=${prefix}/@CMAKE_INSTALL_INCL
+ Name: gd
+ Description: GD graphics library
+-Version: @GDLIB_VERSION@
++Version: @GD_VERSION@
+ Cflags: -I${includedir}
+ Libs.private: @LIBGD_DEP_LIBS@
+ Libs: -L${libdir} -lgd