xtables-addons: bump to 3.24
authorGeorgi Valkov <gvalkov@gmail.com>
Sun, 14 May 2023 15:33:03 +0000 (18:33 +0300)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 14 May 2023 16:17:20 +0000 (18:17 +0200)
fa35c29 Xtables-addons 3.24
9db4d8d DHCPMAC: resolve cppcheck warnings
4599c30 ipv4options: resolve cppcheck warnings
5a714b6 geoip: set autoflush on stdout
f16ed5c geoip: Use stdout for output and stderr for errors/diag
a711985 build: resolve compiler warnings with gcc-13
97181e3 doc, src: improve spelling
30ddb4f doc, src: improve spelling
f3f8155 xt_geoip: bump number of territories per rule
e426ad9 Xtables-addons 3.23
51761c3 build: support for Linux 6.2
409cb5a build: replace `AC_DISABLE_STATIC` macro with an argument to `LT_INIT`
0454ff6 build: replace obsolete `AC_PROG_LIBTOOL` macro with `LT_INIT`
5b3fae8 Xtables-addons 3.22
71396f9 build: support for Linux 6.1
7ad55ad build: eliminate geoip/ make recursion
b950dae build: fix failure to recurse into asn/
cd77880 xt_asn: new module

Signed-off-by: Georgi Valkov <gvalkov@gmail.com>
[ add changelog from 3.21 to 3.24 ]
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
net/xtables-addons/Makefile
net/xtables-addons/patches/001-fix-kernel-version-detection.patch
net/xtables-addons/patches/100-add-rtsp-conntrack.patch
net/xtables-addons/patches/200-add-lua-packetscript.patch

index ccae83f4030605d2309bead55ef3816ce26f322a..cb678ac9cdb36ea74190f70e98b1698f413157df 100644 (file)
@@ -7,9 +7,9 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=xtables-addons
-PKG_VERSION:=3.21
-PKG_RELEASE:=2
-PKG_HASH:=2e09ac129a14f5e9c23b115ebcdfff4aa84e2aeba1268dbdf39b2d752bd71e19
+PKG_VERSION:=3.24
+PKG_RELEASE:=1
+PKG_HASH:=3e823f71720519ced31c4c7d2bfaf7120d9c01c59a0843dfcbe93c95c64d81c1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://inai.de/files/xtables-addons/
index 624fa4d9bfd866dd0601d2e0d45a7eb98cb4ff88..e29b3925cf434ffeb59f6acae5fc1c1a685dfcb7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -42,7 +42,7 @@ regular_CFLAGS="-Wall -Waggregate-return
+@@ -41,7 +41,7 @@ regular_CFLAGS="-Wall -Waggregate-return
  
  AS_IF([test -n "$kbuilddir"], [
        AC_MSG_CHECKING([kernel version that we will build against])
index dbdc52e94638208c1ad7eec85abe0a885dbf031a..befcd06a388ba87b23d5f135d804ed95b2d51753 100644 (file)
 +module_exit(fini);
 --- a/extensions/Kbuild
 +++ b/extensions/Kbuild
-@@ -27,6 +27,7 @@ obj-${build_lscan}       += xt_lscan.o
+@@ -28,6 +28,7 @@ obj-${build_lscan}       += xt_lscan.o
  obj-${build_pknock}      += pknock/
  obj-${build_psd}         += xt_psd.o
  obj-${build_quota2}      += xt_quota2.o
  -include ${M}/Kbuild.*
 --- a/mconfig
 +++ b/mconfig
-@@ -23,3 +23,4 @@ build_lscan=m
+@@ -24,3 +24,4 @@ build_lscan=m
  build_pknock=m
  build_psd=m
  build_quota2=m
index 71b17b660675812063a5d304966f1f184e5d2d9f..2a97f54d75a771e3f90865c19a67ea2ba54cbc1a 100644 (file)
 +
 --- a/extensions/Kbuild
 +++ b/extensions/Kbuild
-@@ -28,6 +28,7 @@ obj-${build_pknock}      += pknock/
+@@ -29,6 +29,7 @@ obj-${build_pknock}      += pknock/
  obj-${build_psd}         += xt_psd.o
  obj-${build_quota2}      += xt_quota2.o
  obj-${build_rtsp}        += rtsp/
  -include ${M}/Kbuild.*
 --- a/extensions/Mbuild
 +++ b/extensions/Mbuild
-@@ -23,3 +23,4 @@ obj-${build_pknock}      += pknock/
+@@ -24,3 +24,4 @@ obj-${build_pknock}      += pknock/
  obj-${build_psd}         += libxt_psd.so
  obj-${build_quota2}      += libxt_quota2.so
  obj-${build_gradm}       += libxt_gradm.so
 +obj-${build_LUA}         += LUA/
 --- a/mconfig
 +++ b/mconfig
-@@ -24,3 +24,4 @@ build_pknock=m
+@@ -25,3 +25,4 @@ build_pknock=m
  build_psd=m
  build_quota2=m
  build_rtsp=m