php7: update to 7.4.26
authorMichael Heimpold <mhei@heimpold.de>
Sat, 20 Nov 2021 11:55:27 +0000 (12:55 +0100)
committerMichael Heimpold <mhei@heimpold.de>
Sat, 20 Nov 2021 23:00:54 +0000 (00:00 +0100)
This fixes:
    - CVE-2021-21707

Also drop upstream patch which is included in the release now.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
(cherry picked from commit c6f27671a303dad64cb7429377ffddb67760ba6a)

lang/php7/Makefile
lang/php7/patches/1011-Accommodate-changes-to-canonicalized-forms-in-ICU-70_1.patch [deleted file]

index a8652db8ec0793fc467763e40fa7d90b5af41ab8..1ec51d7c95cb05a4befa3b2a10c96e5723d71665 100644 (file)
@@ -6,8 +6,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
-PKG_VERSION:=7.4.25
-PKG_RELEASE:=3
+PKG_VERSION:=7.4.26
+PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
 PKG_LICENSE:=PHP-3.01
@@ -16,7 +16,7 @@ PKG_CPE_ID:=cpe:/a:php:php
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www.php.net/distributions/
-PKG_HASH:=12a758f1d7fee544387a28d3cf73226f47e3a52fb3049f07fcc37d156d393c0a
+PKG_HASH:=e305b3aafdc85fa73a81c53d3ce30578bc94d1633ec376add193a1e85e0f0ef8
 
 PKG_BUILD_PARALLEL:=1
 PKG_USE_MIPS16:=0
diff --git a/lang/php7/patches/1011-Accommodate-changes-to-canonicalized-forms-in-ICU-70_1.patch b/lang/php7/patches/1011-Accommodate-changes-to-canonicalized-forms-in-ICU-70_1.patch
deleted file mode 100644 (file)
index 0841905..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-From cd1447a6962496fca60a2f5e5d9cf4448575cc24 Mon Sep 17 00:00:00 2001
-From: Ben Ramsey <ramsey@php.net>
-Date: Tue, 19 Oct 2021 23:59:11 -0500
-Subject: [PATCH 1/4] Change UBool to bool for equality operators in ICU >=
- 70.1
-
-Refer to:
-- https://github.com/unicode-org/icu/commit/633438f8da99fee815e2c61626ea779a84567a3d
-- https://github.com/unicode-org/icu/commit/f6325d49ba57ec26f320b2865ce09ca47db458d9
----
- ext/intl/breakiterator/codepointiterator_internal.cpp | 4 ++++
- ext/intl/breakiterator/codepointiterator_internal.h   | 4 ++++
- 2 files changed, 8 insertions(+)
-
---- a/ext/intl/breakiterator/codepointiterator_internal.cpp
-+++ b/ext/intl/breakiterator/codepointiterator_internal.cpp
-@@ -75,7 +75,11 @@ CodePointBreakIterator::~CodePointBreakI
-       clearCurrentCharIter();
- }
-+#if U_ICU_VERSION_MAJOR_NUM >= 70
-+bool CodePointBreakIterator::operator==(const BreakIterator& that) const
-+#else
- UBool CodePointBreakIterator::operator==(const BreakIterator& that) const
-+#endif
- {
-       if (typeid(*this) != typeid(that)) {
-               return FALSE;
---- a/ext/intl/breakiterator/codepointiterator_internal.h
-+++ b/ext/intl/breakiterator/codepointiterator_internal.h
-@@ -39,7 +39,11 @@ namespace PHP {
-               virtual ~CodePointBreakIterator();
-+#if U_ICU_VERSION_MAJOR_NUM >= 70
-+              virtual bool operator==(const BreakIterator& that) const;
-+#else
-               virtual UBool operator==(const BreakIterator& that) const;
-+#endif
-               virtual CodePointBreakIterator* clone(void) const;
---- a/ext/intl/locale/locale_methods.c
-+++ b/ext/intl/locale/locale_methods.c
-@@ -1326,7 +1326,7 @@ PHP_FUNCTION(locale_filter_matches)
-               if( token && (token==cur_lang_tag) ){
-                       /* check if the char. after match is SEPARATOR */
-                       chrcheck = token + (strlen(cur_loc_range));
--                      if( isIDSeparator(*chrcheck) || isEndOfTag(*chrcheck) ){
-+                      if( isIDSeparator(*chrcheck) || isKeywordSeparator(*chrcheck) || isEndOfTag(*chrcheck) ){
-                               efree( cur_lang_tag );
-                               efree( cur_loc_range );
-                               if( can_lang_tag){