projects
/
feed
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
283b359
)
python: add PYTHONPATH var; this allows packages to configure it
author
Alexandru Ardelean
<aa@ocedo.com>
Wed, 5 Nov 2014 13:18:05 +0000
(15:18 +0200)
committer
Alexandru Ardelean
<aa@ocedo.com>
Fri, 7 Nov 2014 13:37:18 +0000
(15:37 +0200)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/files/python-package.mk
patch
|
blob
|
history
diff --git
a/lang/python/files/python-package.mk
b/lang/python/files/python-package.mk
index 9e48ffc6132137942489cb7b13520e3f5daf77f2..3f714d27f03912fbdf11b88d13d30d01f8f5addd 100644
(file)
--- a/
lang/python/files/python-package.mk
+++ b/
lang/python/files/python-package.mk
@@
-20,8
+20,9
@@
PYTHON:=python$(PYTHON_VERSION)
HOST_PYTHON_LIB_DIR:=$(STAGING_DIR_HOST)/lib/python$(PYTHON_VERSION)
HOST_PYTHON_BIN:=$(STAGING_DIR_HOST)/bin/python2
+PYTHONPATH:=$(PYTHON_LIB_DIR):$(STAGING_DIR)/$(PYTHON_PKG_DIR)
define HostPython
- ( export PYTHONPATH="$(PYTHON
_LIB_DIR):$(STAGING_DIR)/$(PYTHON_PKG_DIR
)"; \
+ ( export PYTHONPATH="$(PYTHON
PATH
)"; \
export PYTHONOPTIMIZE=""; \
export PYTHONDONTWRITEBYTECODE=1; \
$(1) \