xfsprogs: fix compilation with uClibc-ng
authorRosen Penev <rosenp@gmail.com>
Thu, 25 Jun 2020 00:01:36 +0000 (17:01 -0700)
committerRosen Penev <rosenp@gmail.com>
Fri, 26 Jun 2020 00:45:15 +0000 (17:45 -0700)
MAP_SHARED_VALIDATE is completely missing.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/xfsprogs/Makefile
utils/xfsprogs/patches/140-mman.patch

index 335c8f7119d753908f11d13c1d7b6a9072e062b8..c14960e5b72bcb8812ece4aa9a0efca5d9dc636d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xfsprogs
 PKG_VERSION:=5.5.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/xfs/xfsprogs
index 936d3cc29edb3adb23d70958d78602cbf3423de1..fef5d50a24017aa79771e83835b361233dafcf76 100644 (file)
@@ -1,12 +1,16 @@
 --- a/io/mmap.c
 +++ b/io/mmap.c
-@@ -11,6 +11,10 @@
+@@ -11,6 +11,14 @@
  #include "init.h"
  #include "io.h"
  
 +#ifndef MAP_SYNC
 +#define MAP_SYNC 0
 +#endif
++
++#ifndef MAP_SHARED_VALIDATE
++#define MAP_SHARED_VALIDATE 0x03
++#endif
 +
  static cmdinfo_t mmap_cmd;
  static cmdinfo_t mread_cmd;