getdns: disable static linking of getdns utilities
authorJonathan G. Underwood <jonathan.underwood@gmail.com>
Sun, 7 Feb 2021 13:40:36 +0000 (13:40 +0000)
committerJonathan G. Underwood <jonathan.underwood@gmail.com>
Sun, 7 Feb 2021 13:44:47 +0000 (13:44 +0000)
This fixes issue #13361.

Signed-off-by: Jonathan G. Underwood <jonathan.underwood@gmail.com>
libs/getdns/Makefile

index 476368399f382012ddf1f69c7aab5021ff6dc29f..360fb8297d5e6d31a6f9f6f714642093e0d645b9 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=getdns
 PKG_VERSION:=1.6.0
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
@@ -64,6 +64,11 @@ CMAKE_OPTIONS += -DUSE_LIBIDN2=$(if $(CONFIG_GETDNS_ENABLE_IDN_LIBIDN2),ON,OFF)
 # the test for libbsd.
 CMAKE_OPTIONS += -DBSD_LIBRARY=OFF
 
+# Disable static linking to ensure that utility programs such as getdns_query
+# don't end up as large statically linked binaries.
+CMAKE_OPTIONS += -DENABLE_STATIC=OFF
+CMAKE_OPTIONS += -DENABLE_SHARED=ON  # This is the default
+
 define Package/getdns/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgetdns.so.* $(1)/usr/lib/