luaposix: update to v33.0.0
authorMaxim Storchak <m.storchak@gmail.com>
Sun, 14 Dec 2014 10:54:02 +0000 (12:54 +0200)
committerMaxim Storchak <m.storchak@gmail.com>
Sun, 14 Dec 2014 11:02:42 +0000 (13:02 +0200)
Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
lang/luaposix/Makefile
lang/luaposix/patches/100-eglibc-compat.patch
lang/luaposix/patches/101-disable-curses.patch [new file with mode: 0644]

index 29f1a676fe6d1e63c1183ebd4337409cb5037f0a..a3cd736da32a78058586707c42574d022124141b 100644 (file)
@@ -8,17 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=luaposix
-PKG_VERSION:=v32
+PKG_VERSION:=v33.0.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=release-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/luaposix/luaposix/archive/
-PKG_MD5SUM:=2bfede7b7cee96c5d0f6c0354e17498c
+PKG_MD5SUM:=3241c33566542b7563ae001112646af6
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-release-$(PKG_VERSION)
 PKG_REMOVE_FILES:=aclocal.m4
 PKG_FIXUP:=autoreconf
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
 PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=COPYING
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -48,7 +49,7 @@ endif
 
 define Package/luaposix/install
        $(INSTALL_DIR) $(1)/usr/lib/lua
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ext/posix/.libs/posix_c.so $(1)/usr/lib/lua
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ext/posix/.libs/posix.so $(1)/usr/lib/lua
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/posix.lua $(1)/usr/lib/lua
 endef
 
index 0cdff83d2c351c71b374ebd5428fa9d1c4d62f0f..7fc028596f4b023a7fad01543a310db1c5c30829 100644 (file)
@@ -1,28 +1,29 @@
---- a/ext/posix/posix.c
-+++ b/ext/posix/posix.c
-@@ -1970,6 +1970,7 @@ static int Pctermid(lua_State *L)
-       return 1;
- }
+diff -Naur luaposix-release-v33.0.0.orig/ext/posix/unistd.c luaposix-release-v33.0.0/ext/posix/unistd.c
+--- luaposix-release-v33.0.0.orig/ext/posix/unistd.c   2014-11-04 17:49:35.000000000 +0200
++++ luaposix-release-v33.0.0/ext/posix/unistd.c        2014-12-14 00:59:14.878622722 +0200
+@@ -526,6 +526,7 @@
+ #endif
  
 +#ifndef NO_GETLOGIN
  /***
  Current logged-in user.
- @see getlogin(3)
-@@ -1980,6 +1981,7 @@ static int Pgetlogin(lua_State *L)
-       lua_pushstring(L, getlogin());
-       return 1;
+ @treturn[1] string username, if successful
+@@ -538,6 +539,7 @@
+       checknargs(L, 0);
+       return pushstringresult(getlogin());
  }
 +#endif
  
- static void Fgetpasswd(lua_State *L, int i, const void *data)
- {
-@@ -3786,7 +3788,9 @@ static const luaL_Reg R[] =
- #if _POSIX_VERSION >= 200112L
-       MENTRY( Pgetgroups      ),
- #endif
+ /***
+@@ -1037,7 +1039,9 @@
+       LPOSIX_FUNC( Pgetegid           ),
+       LPOSIX_FUNC( Pgeteuid           ),
+       LPOSIX_FUNC( Pgetgid            ),
 +#ifndef NO_GETLOGIN
-       MENTRY( Pgetlogin       ),
+       LPOSIX_FUNC( Pgetlogin          ),
 +#endif
-       MENTRY( Pgetopt         ),
-       MENTRY( Pgetpasswd      ),
-       MENTRY( Pgetpid         ),
+       LPOSIX_FUNC( Pgetpgrp           ),
+       LPOSIX_FUNC( Pgetpid            ),
+       LPOSIX_FUNC( Pgetppid           ),
diff --git a/lang/luaposix/patches/101-disable-curses.patch b/lang/luaposix/patches/101-disable-curses.patch
new file mode 100644 (file)
index 0000000..0ea052b
--- /dev/null
@@ -0,0 +1,30 @@
+diff -Naur luaposix-release-v33.0.0.orig/ext/posix/posix.c luaposix-release-v33.0.0/ext/posix/posix.c
+--- luaposix-release-v33.0.0.orig/ext/posix/posix.c    2014-11-04 17:49:35.000000000 +0200
++++ luaposix-release-v33.0.0/ext/posix/posix.c 2014-12-14 01:49:44.486562194 +0200
+@@ -11,7 +11,6 @@
+  */
+ #include "ctype.c"
+-#include "curses.c"
+ #include "dirent.c"
+ #include "errno.c"
+ #include "fcntl.c"
+diff -Naur luaposix-release-v33.0.0.orig/configure.ac luaposix-release-v33.0.0/configure.ac
+--- luaposix-release-v33.0.0.orig/configure.ac 2014-11-04 17:49:35.000000000 +0200
++++ luaposix-release-v33.0.0/configure.ac      2014-12-14 01:58:08.214554482 +0200
+@@ -109,15 +109,6 @@
+   AC_SUBST([LIBRT], [-lrt])
+ fi
+-dnl Curses
+-AX_WITH_CURSES
+-AC_ARG_VAR(CURSES_LIB, [linker flags for curses library])
+-
+-save_LIBS=$LIBS
+-LIBS="$CURSES_LIB $LIBS"
+-AC_CHECK_FUNCS([resizeterm])
+-LIBS=$save_LIBS
+-
+ dnl Lua 5.1 or 5.2
+ AX_PROG_LUA(5.1, 5.3)
+ AX_LUA_HEADERS