dtndht: Fix install target
authorJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Fri, 22 Aug 2014 11:57:02 +0000 (13:57 +0200)
committerJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Fri, 22 Aug 2014 12:07:51 +0000 (14:07 +0200)
The previous copying command includes non-existing variables. This commit replaces
the command with a more generic one.

Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
libs/dtndht/Makefile

index 6bc808425204e77b9fa81a81654cda667aa2c844..7ab618145bdf891b6a21cc7c58e8435b40811c37 100644 (file)
@@ -41,7 +41,7 @@ endef
 
 define Package/dtndht/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib$(PKG_NAME){.so,-$(PKG_VERSION_MAJOR).$(PKG_VERSION_MINOR).so.*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,dtndht))