dawn: bump version
authorNick Hainke <vincent@systemli.org>
Fri, 7 Aug 2020 10:28:26 +0000 (12:28 +0200)
committerNick Hainke <vincent@systemli.org>
Fri, 7 Aug 2020 10:35:59 +0000 (12:35 +0200)
test_storage: fix compilation with musl 1.2.0
datastorage/test: improve scalability and performance
datastorage: fixed use of wrong client search
general: add memory auditing
memory auditing: bug fixes to memory auditing and hearing map
datastorage: fixes to linked list handling
tcpsocket: fix read callback function and arbitrary memory allocations
tcpsocket: leave loop if we read 0 byte

Furthermore, you can now dump the memory usage by sending a SIGHUP to
dawn process.

Signed-off-by: Nick Hainke <vincent@systemli.org>
net/dawn/Makefile

index f7f1bc862de97ced7149302c6a17bee5bafecdb8..ef325b3ae52a3e3c5421f0ebdae8124aa48e7ebd 100644 (file)
@@ -5,13 +5,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dawn
-PKG_SOURCE_DATE:=2020-07-12
+PKG_SOURCE_DATE:=2020-08-07
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/berlin-open-wireless-lab/DAWN.git
-PKG_SOURCE_VERSION:=32640de37836f674429aab1ff06f26c27c2c0986
-PKG_MIRROR_HASH:=82d55383d6594dae46f2eb11b65f217f3e994e3ce3d655aa1c5a7ac80a5c8d63
+PKG_SOURCE_VERSION:=50d54a625366cffd48f0ec3f23456d5a04c45fd3
+PKG_MIRROR_HASH:=cdea4f6ff0209afa0320e143043e0417fd6d65c349651e491f6023affd39fa10
 
 PKG_MAINTAINER:=Nick Hainke <vincent@systemli.org>
 PKG_LICENSE:=GPL-2.0-only