znc: Clean up Makefile and fix compilation on PPC
authorRosen Penev <rosenp@gmail.com>
Mon, 22 Apr 2019 18:24:53 +0000 (11:24 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 23 Apr 2019 01:39:18 +0000 (18:39 -0700)
Some of these hacks were needed when uClibc++ was used. Now that it is not
we can remove them.

Remove libpthread dependency. Not only is it unneeded, package-defaults
already specifies it.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/znc/Makefile

index bbaba22130503e2266cc5458ca899ea1933ee2c8..efc98059984a15a5ab674655070369754cb684a3 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=znc
 PKG_VERSION:=1.7.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://znc.in/releases \
@@ -37,7 +37,7 @@ endef
 
 define Package/znc
   $(Package/znc/default)
-  DEPENDS:=+libopenssl +libpthread +libstdcpp +ZNC_ICU:icu +zlib
+  DEPENDS:=+libopenssl +libstdcpp +ZNC_ICU:icu +zlib
   MENU:=1
 endef
 
@@ -279,12 +279,6 @@ PKG_CONFIG_DEPENDS += $(patsubst %,CONFIG_PACKAGE_%,$(ZNC_MODULES))
 
 include $(INCLUDE_DIR)/package.mk
 
-CONFIGURE_VARS += \
-       CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin" \
-       CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-       LDFLAGS="-nodefaultlibs -lc -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-       LIBS="-lstdc++ -lm -lssl -lcrypto $(LIBGCC_S) -lc"
-
 CONFIGURE_ARGS += \
        $(if $(CONFIG_ZNC_ICU), --enable-charset, --disable-charset) \
        --disable-cyrus \
@@ -299,11 +293,6 @@ CONFIGURE_ARGS += \
        --enable-tdns \
        --enable-zlib
 
-define Build/Configure
-       $(call Build/Configure/Default,)
-       $(call libtool_disable_rpath)
-endef
-
 define Build/Compile
        $(call Build/Compile/Default,znc)
        +$(MAKE_VARS) $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)/modules \