freetype: remove host build
authorRosen Penev <rosenp@gmail.com>
Thu, 28 May 2020 20:50:26 +0000 (13:50 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 2 Jun 2020 21:02:54 +0000 (14:02 -0700)
Nothing uses this.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/freetype/Makefile

index 0dd7bf70055f3f31792aaf842e013f1013066fb5..fc7813e6700daaca4f9e7e151cc759837be99744 100644 (file)
@@ -23,7 +23,6 @@ PKG_MAINTAINER:=Val Kulkov <val.kulkov@gmail.com>
 PKG_FIXUP:=autoreconf
 PKG_LIBTOOL_PATHS:=builds/unix
 
-include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libfreetype
@@ -51,11 +50,6 @@ CONFIGURE_ARGS += \
        --with-zlib=yes \
        --with-png=yes
 
-HOST_CONFIGURE_ARGS+= \
-       --with-bzip2=no \
-       --with-zlib=no \
-       --with-png=no
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
@@ -84,5 +78,4 @@ define Package/libfreetype/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.so.* $(1)/usr/lib/
 endef
 
-$(eval $(call HostBuild))
 $(eval $(call BuildPackage,libfreetype))