kernel: armsr: Renesas: RZ: Ethernet module and ttySC0
authorJohn Vincent <john.vincent.xa@bp.renesas.com>
Fri, 31 May 2024 13:56:24 +0000 (14:56 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 6 Jul 2024 16:37:39 +0000 (18:37 +0200)
Ethernet module enable for Renesas RZ platform
inittab fix for ttySC0

Fixes: #15284
Signed-off-by: John Vincent <john.vincent.xa@bp.renesas.com>
(cherry picked from commit 531b3f667c40405581a398a9648a0e6c27909a87)
Link: https://github.com/openwrt/openwrt/pull/15808
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/armsr/base-files/etc/inittab
target/linux/armsr/image/Makefile
target/linux/armsr/modules.mk

index 51832eb77564f8b004b70189509cc408640f1e4d..9c574d8d6c95c2d3f5fc8db4ca8fd574ad919b3b 100644 (file)
@@ -7,3 +7,4 @@ hvc0::askfirst:/usr/libexec/login.sh
 ttymxc0::askfirst:/usr/libexec/login.sh
 ttymxc1::askfirst:/usr/libexec/login.sh
 ttymxc2::askfirst:/usr/libexec/login.sh
+ttySC0::askfirst:/usr/libexec/login.sh
index 1df9657385dc624eb22a35c0233cdf1a61d59311..21f4c7dc547f6827b1fee85fa91a6883eead5890 100644 (file)
@@ -112,7 +112,7 @@ define Device/generic
        kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-thunderx-net \
        kmod-dwmac-rockchip kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom \
        kmod-phy-marvell kmod-phy-marvell-10g kmod-sfp kmod-atlantic \
-       kmod-bcmgenet kmod-octeontx2-net
+       kmod-bcmgenet kmod-octeontx2-net kmod-renesas-net-avb
 endef
 TARGET_DEVICES += generic
 
index 9c7fe0c04ffc9c9f33e18aaa5f9b2554b0738e0a..5d55ea74cb33fb3f77c808134749d310a6489658 100644 (file)
@@ -314,6 +314,21 @@ define KernelPackage/octeontx2-net
 endef
 $(eval $(call KernelPackage,octeontx2-net))
 
+define KernelPackage/renesas-net-avb
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=Renesas network drivers
+  DEPENDS:=@(TARGET_armsr_armv8) +kmod-phylink +kmod-mii +kmod-ptp +kmod-libphy +kmod-mdio-gpio
+  KCONFIG:=CONFIG_RAVB
+  FILES=$(LINUX_DIR)/drivers/net/ethernet/renesas/ravb.ko
+  AUTOLOAD:=$(call AutoProbe,ravb)
+endef
+define KernelPackage/renesas-net-avb/description
+  Support Renesas RZ platform Ethernet module
+endef
+$(eval $(call KernelPackage,renesas-net-avb))
+
 define KernelPackage/wdt-sp805
   SUBMENU:=$(OTHER_MENU)
   TITLE:=ARM SP805 Watchdog