frr: add support for BGP MD5 authentication
authorMartin Schiller <ms@dev.tdt.de>
Thu, 16 May 2024 12:24:33 +0000 (14:24 +0200)
committerTianling Shen <cnsztl@gmail.com>
Mon, 3 Jun 2024 09:35:55 +0000 (17:35 +0800)
You have to enable the CONFIG_TCP_MD5SIG kernel config option to be able
to use the BGP MD5 authentication.

Signed-off-by: Martin Schiller <ms@dev.tdt.de>
net/frr/Makefile

index ccd68ae527b01e63d7ee163f76739be63015828a..14249fe61806c1678f43f2835e0e954f6b17b5d6 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 PKG_NAME:=frr
 PKG_VERSION:=9.0.0
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_SOURCE_DATE:=2023-08-12
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz
@@ -128,6 +128,9 @@ define BuildDaemon
     define Package/frr-$(1)
        $$(call Package/frr/Default)
        TITLE:= $(1) routing engine
+ifeq ($(1),bgpd)
+       KCONFIG:=CONFIG_TCP_MD5SIG=y
+endif
        DEPENDS+=$(2)
     endef
 #      if [ "$(1)" == "bfdd" ]; then \