kernel: hwmon: add tc654 driver
authorZoltan HERPAI <wigyori@uid0.hu>
Fri, 19 Feb 2021 15:59:29 +0000 (16:59 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Mon, 31 Jan 2022 17:54:47 +0000 (18:54 +0100)
Kernel module for Microchip TC654/655 fan speed controller.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/kernel/linux/modules/hwmon.mk

index 943b87cd4ce3206aa998df047d5350efd98e469f..64f534862030c04cd90a421780b55f7a13573ca0 100644 (file)
@@ -457,6 +457,21 @@ endef
 $(eval $(call KernelPackage,hwmon-sht21))
 
 
+define KernelPackage/hwmon-tc654
+  TITLE:=TC654 monitoring support
+  KCONFIG:=CONFIG_SENSORS_TC654
+  FILES:=$(LINUX_DIR)/drivers/hwmon/tc654.ko
+  AUTOLOAD:=$(call AutoLoad,60,tc654)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-tc654/description
+ Kernel module for Microchip TC654/TC655 and compatibles
+endef
+
+$(eval $(call KernelPackage,hwmon-tc654))
+
+
 define KernelPackage/hwmon-tmp102
   TITLE:=Texas Instruments TMP102 monitoring support
   KCONFIG:=CONFIG_SENSORS_TMP102