transmission: update to 2.20b4, add new options
authorCezary Jackiewicz <cezary@eko.one.pl>
Sun, 6 Feb 2011 15:41:24 +0000 (15:41 +0000)
committerCezary Jackiewicz <cezary@eko.one.pl>
Sun, 6 Feb 2011 15:41:24 +0000 (15:41 +0000)
SVN-Revision: 25387

net/transmission/Makefile
net/transmission/files/transmission.config
net/transmission/files/transmission.init

index c336131396ec0c075278eb7baf8f6da58ed5b5f8..c1e2377d7a69504e12534036072c3f37fae5f7a2 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
-PKG_VERSION:=2.20b3
+PKG_VERSION:=2.20b4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
-PKG_MD5SUM:=837a2d53ed1e761cbd4d2e19c8652f8c
+PKG_MD5SUM:=37d1f1a9ff9971e61b62498fd144ae32
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
index dbc5407e7cf22370f2c512abb3b005295eba9539..bacacccdf427a55585c110fea9f8e6a2cbbb15e5 100644 (file)
@@ -34,6 +34,7 @@ config transmission
        option pex_enabled true
        option port_forwarding_enabled true
        option preallocation 1
+       option prefetch_enabled 1
        option ratio_limit 2.0000
        option ratio_limit_enabled false
        option rename_partial_files true
@@ -42,6 +43,7 @@ config transmission
        option rpc_enabled true
        option rpc_password ''
        option rpc_port 9091
+       option rpc_url '/transmission/'
        option rpc_username ''
        option rpc_whitelist '127.0.0.1,192.168.1.*'
        option rpc_whitelist_enabled true
index eec3b56e2b49099c81fd5b939931a8f114ff54d9..c3e870377af5be9dec9b24551eebbc49331bd60b 100644 (file)
@@ -58,7 +58,7 @@ start_service() {
                incomplete_dir_enabled lazy_bitfield_enabled lpd_enabled message_level \
                open_file_limit peer_limit_global peer_limit_per_torrent peer_port \
                peer_port_random_high peer_port_random_low peer_port_random_on_start \
-               peer_socket_tos pex_enabled port_forwarding_enabled preallocation \
+               peer_socket_tos pex_enabled port_forwarding_enabled preallocation prefetch_enabled \
                ratio_limit ratio_limit_enabled rename_partial_files rpc_authentication_required \
                rpc_enabled rpc_port rpc_whitelist_enabled script_torrent_done_enabled \
                speed_limit_down speed_limit_down_enabled speed_limit_up \
@@ -67,7 +67,7 @@ start_service() {
 
        append_params_quotes "$s" \
                blocklist_url bind_address_ipv4 bind_address_ipv6 download_dir incomplete_dir \
-               rpc_bind_address rpc_password \
+               rpc_bind_address rpc_password rpc_url \
                rpc_username rpc_whitelist script_torrent_done_filename watch_dir
 
        echo "\""invalid-key"\": false" >> $config_dir/settings.json