projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d312603
)
powerpc/vdso64: Drop vdso64as
author
Michael Ellerman
<mpe@ellerman.id.au>
Thu, 11 Aug 2016 06:03:12 +0000
(16:03 +1000)
committer
Michael Ellerman
<mpe@ellerman.id.au>
Tue, 13 Sep 2016 07:37:05 +0000
(17:37 +1000)
We can just use the standard .S -> .o rule, cmd_as_o_S.
Signed-off-by: Michael Ellerman <mpe@ellerman.id.au>
arch/powerpc/kernel/vdso64/Makefile
patch
|
blob
|
history
diff --git
a/arch/powerpc/kernel/vdso64/Makefile
b/arch/powerpc/kernel/vdso64/Makefile
index 366ae09b14c1e3a5179987d312ec4d1fedf86313..31107bf5a61f85ea118ae36900bc2c627f432161 100644
(file)
--- a/
arch/powerpc/kernel/vdso64/Makefile
+++ b/
arch/powerpc/kernel/vdso64/Makefile
@@
-31,15
+31,9
@@
$(obj)/%.so: OBJCOPYFLAGS := -S
$(obj)/%.so: $(obj)/%.so.dbg FORCE
$(call if_changed,objcopy)
-# assembly rules for the .S files
-$(obj-vdso64): %.o: %.S FORCE
- $(call if_changed_dep,vdso64as)
-
# actual build commands
quiet_cmd_vdso64ld = VDSO64L $@
cmd_vdso64ld = $(CC) $(c_flags) -o $@ -Wl,-T$(filter %.lds,$^) $(filter %.o,$^)
-quiet_cmd_vdso64as = VDSO64A $@
- cmd_vdso64as = $(CC) $(a_flags) -c -o $@ $<
# install commands for the unstripped file
quiet_cmd_vdso_install = INSTALL $@