file: Fix FTBFS due to missing dependency
authorVolker Christian <me@vchrist.at>
Sat, 5 Aug 2023 18:00:00 +0000 (20:00 +0200)
committerTianling Shen <cnsztl@gmail.com>
Mon, 28 Aug 2023 00:53:28 +0000 (08:53 +0800)
Fixes #21583

zstdlib and lzlib support is currently not neccessary for OpenWRT.
Thus, Explicitly disable zstdlib and lzlib as they would be enabled
automatically in case they are already installed.

Signed-off-by: Volker Christian <me@vchrist.at>
(cherry picked from commit 3ee4f030b525d8d7c56605735df1c44d1362f026)

libs/file/Makefile

index 25941eccec54752321037540a6fad7f2ddf04f6e..eaf8e501d7a35ab7e3cd8730bd3bfe3cd702497e 100644 (file)
@@ -56,8 +56,10 @@ CONFIGURE_ARGS += \
        --enable-xzlib \
        --enable-zlib \
        --disable-libseccomp \
+       --disable-lzlib \
        --disable-rpath \
        --disable-warnings \
+       --disable-zstdlib \
        --without-pic
 
 MAKE_PATH := src