wavemon: Update to 0.9.0
authorRosen Penev <rosenp@gmail.com>
Tue, 29 Jan 2019 00:03:02 +0000 (16:03 -0800)
committerRosen Penev <rosenp@gmail.com>
Sat, 30 Mar 2019 05:49:07 +0000 (22:49 -0700)
Added PKG_BUILD_PARALLEL for faster compilation

Backported upstream patch to fix compilation with musl.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/wavemon/Makefile
net/wavemon/patches/010-Scan-screen-resolves-62.patch [new file with mode: 0644]

index c15948dc3733190b77da5a0c507d808fa58d835a..8634c1e7542e6f8dfd9d90970158277912a06812 100644 (file)
@@ -8,17 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wavemon
-PKG_VERSION:=0.8.2
-PKG_RELEASE:=2
+PKG_VERSION:=0.9.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/uoaerg/wavemon/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=4199e2ad11a036f4289f5ad42a8b0fe518f2b5ff77447f4c366dbcf3f23e91d5
+PKG_HASH:=5823ef9459d6147a457b390b6744a77465584e93d37c2809fa7a0be557070166
 
+PKG_MAINTAINER:=Jonathan McCrohan <jmccrohan@gmail.com>
 PKG_LICENSE:=GPL-2.0+
 PKG_LICENSE_FILES:=COPYING
-PKG_MAINTAINER:=Jonathan McCrohan <jmccrohan@gmail.com>
 
+PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -39,14 +40,9 @@ define Package/wavemon/description
   and higher), e.g. the Lucent Orinoco cards.
 endef
 
-CONFIGURE_VARS += \
-       ac_cv_lib_cap_cap_get_flag=no \
-       BUILD_DATE=$(SOURCE_DATE_EPOCH)
-
-TARGET_CFLAGS += -pthread -I$(STAGING_DIR)/usr/include/libnl3
+CONFIGURE_ARGS += --without-libcap
 
-MAKE_FLAGS += \
-       CFLAGS="$(TARGET_CFLAGS) -L$(STAGING_DIR)/usr/lib -I$(STAGING_DIR)/usr/include"
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/libnl3
 
 define Package/wavemon/install
        $(INSTALL_DIR) $(1)/usr/bin
diff --git a/net/wavemon/patches/010-Scan-screen-resolves-62.patch b/net/wavemon/patches/010-Scan-screen-resolves-62.patch
new file mode 100644 (file)
index 0000000..ea9e209
--- /dev/null
@@ -0,0 +1,62 @@
+From f6e20c9c6e9b50963caaf5483248d329473a6815 Mon Sep 17 00:00:00 2001
+From: Gerrit Renker <Gerrit.Renker@ctl.io>
+Date: Mon, 21 Jan 2019 09:23:43 -0700
+Subject: [PATCH] Scan screen: resolves #62
+
+---
+ iw_if.c   | 10 ++++++----
+ iw_if.h   |  2 +-
+ iw_scan.c |  2 +-
+ 3 files changed, 8 insertions(+), 6 deletions(-)
+
+diff --git a/iw_if.c b/iw_if.c
+index c0b0128..d8bacbc 100644
+--- a/iw_if.c
++++ b/iw_if.c
+@@ -87,11 +87,13 @@ int if_set_down(const char *ifname)
+       return if_set_up_or_down(ifname, false);
+ }
+-/** Exit handler to restore interface 'down' state on exit via on_exit(3). */
+-void if_set_down_on_exit(int rc, void *arg)
++/** Exit handler to restore interface 'down' state on exit via atexit(3). */
++void if_set_down_on_exit(void)
+ {
+-      if (if_set_down(arg) < 0) {
+-              err_msg("unable to restore %s interface state - set down manually", arg);
++      const char *ifname = conf_ifname();
++
++      if (ifname && if_set_down(ifname) < 0) {
++              err_msg("unable to restore %s interface state - set down manually", ifname);
+       }
+ }
+diff --git a/iw_if.h b/iw_if.h
+index 50f5a47..e2199d3 100644
+--- a/iw_if.h
++++ b/iw_if.h
+@@ -76,7 +76,7 @@ struct if_info {
+ };
+ extern bool if_is_up(const char *ifname);
+ extern int  if_set_up(const char *ifname);
+-extern void if_set_down_on_exit(int rc, void *arg);
++extern void if_set_down_on_exit(void);
+ extern void if_getinf(const char *ifname, struct if_info *info);
+ /**
+diff --git a/iw_scan.c b/iw_scan.c
+index 18e9e06..e2b3067 100644
+--- a/iw_scan.c
++++ b/iw_scan.c
+@@ -430,7 +430,7 @@ void *do_scan(void *sr_ptr)
+                               if (if_set_up(conf_ifname()) < 0)
+                                       err_sys("Can not bring up interface '%s'", conf_ifname());
+-                              if (on_exit(if_set_down_on_exit, (void *)conf_ifname()) < 0)
++                              if (atexit(if_set_down_on_exit) < 0)
+                                       snprintf(sr->msg, sizeof(sr->msg), "Warning: unable to restore %s down state on exit", conf_ifname());
+                               break;
+                       }
+-- 
+2.17.1
+