curl: bump to 7.83.1
authorStan Grishin <stangri@melmac.ca>
Thu, 19 May 2022 09:17:21 +0000 (09:17 +0000)
committerStan Grishin <stangri@melmac.ca>
Mon, 6 Jun 2022 22:53:14 +0000 (22:53 +0000)
* https://curl.se/changes.html#7_83_1

Signed-off-by: Stan Grishin <stangri@melmac.ca>
(cherry picked from commit b0f213a726a019fa864420fc9d50523ab8ec8901)

net/curl/Makefile
net/curl/patches/0001-wolfssl-fix-compiler-error-without-IPv6.patch [deleted file]
net/curl/patches/200-no_docs_tests.patch

index 08ab67c2e60262d5fe05fbce9f34d19774ce0cd7..827af43d224c703acd4022d7e7d7a877be6ad8a3 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.82.0
+PKG_VERSION:=7.83.1
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
        https://curl.askapache.com/download/ \
        https://curl.se/download/
-PKG_HASH:=0aaa12d7bd04b0966254f2703ce80dd5c38dbbd76af0297d3d690cdce58a583c
+PKG_HASH:=2cb9c2356e7263a1272fd1435ef7cdebf2cd21400ec287b068396deb705c22c4
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
diff --git a/net/curl/patches/0001-wolfssl-fix-compiler-error-without-IPv6.patch b/net/curl/patches/0001-wolfssl-fix-compiler-error-without-IPv6.patch
deleted file mode 100644 (file)
index 5d68d1e..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-From 471d5f44c5189bd78f8839ce8ac1b4b14f4b7d61 Mon Sep 17 00:00:00 2001
-From: Daniel Stenberg <daniel@haxx.se>
-Date: Mon, 7 Mar 2022 08:40:47 +0100
-Subject: [PATCH] wolfssl: fix compiler error without IPv6
-
-Reported-by: Joseph Chen
-Fixes #8550
-Closes #8552
----
- lib/vtls/wolfssl.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/lib/vtls/wolfssl.c
-+++ b/lib/vtls/wolfssl.c
-@@ -462,9 +462,9 @@ wolfssl_connect_step1(struct Curl_easy *
-     const char * const hostname = SSL_HOST_NAME();
-     size_t hostname_len = strlen(hostname);
-     if((hostname_len < USHRT_MAX) &&
--       (0 == Curl_inet_pton(AF_INET, hostname, &addr4)) &&
-+       !Curl_inet_pton(AF_INET, hostname, &addr4)
- #ifdef ENABLE_IPV6
--       (0 == Curl_inet_pton(AF_INET6, hostname, &addr6))
-+       && !Curl_inet_pton(AF_INET6, hostname, &addr6)
- #endif
-       ) {
-       size_t snilen;
index 274afc69876dd2d7ea685136e3b2976569ecc6cf..463aeac0b026da5fe06e65a2e4c3a7522fc956f3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -156,7 +156,7 @@ CLEANFILES = $(VC10_LIBVCXPROJ) $(VC10_S
+@@ -155,7 +155,7 @@ CLEANFILES = $(VC10_LIBVCXPROJ) $(VC10_S
  bin_SCRIPTS = curl-config
  
  SUBDIRS = lib src
@@ -9,7 +9,7 @@
  
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
-@@ -270,8 +270,6 @@ cygwinbin:
+@@ -269,8 +269,6 @@ cygwinbin:
  # We extend the standard install with a custom hook:
  install-data-hook:
        (cd include && $(MAKE) install)