libgd: avoid recursive and redundant dependencies
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Wed, 14 Sep 2022 21:32:47 +0000 (18:32 -0300)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Thu, 6 Oct 2022 09:45:50 +0000 (11:45 +0200)
Change the CONFLICTS line from the libgd-full to libgd to fix a
recursive dependency.

While at it, remove the redundant +LIBGD_TIFF:libtiff
+LIBGD_FREETYPE:libfreetype dependencies from Package/libgd/default.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
(cherry picked from commit 085eb34fbf7c7aaa20da35ebe2f493601c5f19b2)

libs/libgd/Makefile

index 7240cd7fca9c6ed21f2c052e073b19014ba8cd77..8e16645898767aa150eb2020ea96fc04319f332d 100644 (file)
@@ -28,7 +28,7 @@ include $(INCLUDE_DIR)/cmake.mk
 define Package/libgd/default
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libjpeg +libpng +libwebp +LIBGD_TIFF:libtiff +LIBGD_FREETYPE:libfreetype
+  DEPENDS:=+libjpeg +libpng +libwebp
   TITLE:=The GD graphics library
   URL:=https://libgd.github.io/
 endef
@@ -38,6 +38,7 @@ define Package/libgd
   MENU:=1
   DEPENDS+=+LIBGD_TIFF:libtiff +LIBGD_FREETYPE:libfreetype
   VARIANT:=default
+  CONFLICTS:=libgd-full
 endef
 
 define Package/libgd-full
@@ -46,7 +47,6 @@ define Package/libgd-full
   TITLE+=(full)
   VARIANT:=full
   PROVIDES:=libgd
-  CONFLICTS:=libgd
 endef
 
 define Package/libgd/description/default