python[3]-simplejson: drop tests from simplejson package
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Tue, 8 Oct 2019 13:53:35 +0000 (16:53 +0300)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Tue, 8 Oct 2019 13:53:36 +0000 (16:53 +0300)
These tests take-up a bit of space. And they aren't typically needed.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/python-simplejson/Makefile

index a975200204a21440a9e2c65ed4013f5a46106e4c..6b2d454326372d231a3d9bce7431eadc73346654 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-simplejson
 PKG_VERSION:=3.16.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_LICENSE:=MIT
 PKG_CPE_ID:=cpe:/a:simplejson_project:simplejson
 
@@ -56,6 +56,16 @@ $(call Package/python-simplejson/description)
 (Variant for Python3)
 endef
 
+define PyPackage/python-simplejson/filespec
++|$(PYTHON_PKG_DIR)
+-|$(PYTHON_PKG_DIR)/simplejson/tests
+endef
+
+define Py3Package/python3-simplejson/filespec
++|$(PYTHON3_PKG_DIR)
+-|$(PYTHON3_PKG_DIR)/simplejson/tests
+endef
+
 $(eval $(call PyPackage,python-simplejson))
 $(eval $(call BuildPackage,python-simplejson))
 $(eval $(call BuildPackage,python-simplejson-src))