exim: add default config and init script, enable lmtp
authorDaniel Golle <daniel@makrotopia.org>
Wed, 11 Aug 2021 22:41:42 +0000 (23:41 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 12 Aug 2021 02:11:40 +0000 (03:11 +0100)
Ship default configuration /etc/exim/exim.conf as well as
a simple procd init script. Enable building with LMTP for better
integration with dovecot.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
mail/exim/Makefile
mail/exim/files/exim.init [new file with mode: 0644]

index 013d8a140139634aa10c83a2ee21918b92f5fd38..289aa891b1f2f87d92a5d5b885f878f9ad753d2d 100644 (file)
@@ -159,6 +159,7 @@ define Build/Configure
        $(SED) 's%# SUPPORT_MBX=yes%SUPPORT_MBX=yes%' $(PKG_BUILD_DIR)/Local/Makefile
 # enable lookup modules
        $(SED) 's%# LOOKUP_DSEARCH=yes%LOOKUP_DSEARCH=yes%' $(PKG_BUILD_DIR)/Local/Makefile
+       $(SED) 's%# TRANSPORT_LMTP=yes%TRANSPORT_LMTP=yes%' $(PKG_BUILD_DIR)/Local/Makefile
 ifdef CONFIG_PACKAGE_exim-lookup-dbmdb
        $(SED) 's%LOOKUP_DBM=yes%LOOKUP_DBM=2%' $(PKG_BUILD_DIR)/Local/Makefile
 else
@@ -265,6 +266,10 @@ endef
 define Package/exim/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/build-Linux-$(ARCH)/exim $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/exim
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/configure.default $(1)/etc/exim/exim.conf
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/exim.init $(1)/etc/init.d/exim
 endef
 
 Package/exim-gnutls/install = $(Package/exim/install)
diff --git a/mail/exim/files/exim.init b/mail/exim/files/exim.init
new file mode 100644 (file)
index 0000000..ed4a979
--- /dev/null
@@ -0,0 +1,19 @@
+#!/bin/sh /etc/rc.common
+
+START=80
+STOP=80
+
+USE_PROCD=1
+
+start_service() {
+       mkdir -p -m 0755 /var/lib/exim
+       mkdir -p -m 0755 /var/run/exim
+       chmod 0750 /var/lib/exim
+       procd_open_instance
+       procd_set_param command /usr/sbin/exim
+       procd_append_param command -C /etc/exim/exim.conf
+       procd_append_param command -bd -q15m
+       procd_set_param stdout 1
+       procd_set_param stderr 1
+       procd_close_instance
+}