xtables-addons: pass correct flags to compile and install
authorSébastien Blin <sebastien.blin@savoirfairelinux.com>
Sat, 2 Mar 2019 15:31:22 +0000 (10:31 -0500)
committerEneas Queiroz <cote2004-github@yahoo.com>
Tue, 21 May 2019 19:22:49 +0000 (16:22 -0300)
The Makefile currently redefine the Compile and Install functions.
This is not working when using an external toolchain because some
flags are not interpreted, like CROSS_COMPILE. It is possible to
override the MAKE_FLAGS and MAKE_INSTALL_FLAGS instead.

Signed-off-by: Sébastien Blin <sebastien.blin@savoirfairelinux.com>
net/xtables-addons/Makefile

index ee1ad44a39f8b9dcb6730ebcb4aa64d28674198b..948f2b826b6b3ee15b680df4d5c5c9b99f1bf7eb 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=xtables-addons
 PKG_VERSION:=2.14
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 PKG_HASH:=d215a9a8b8e66aae04b982fa2e1228e8a71e7dfe42320df99e34e5000cbdf152
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -39,23 +39,13 @@ endef
 
 CONFIGURE_ARGS+= \
        --with-kbuild="$(LINUX_DIR)" \
-       --with-xtlibdir="/usr/lib/iptables" \
-
-define Build/Compile
-       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               $(KERNEL_MAKE_FLAGS) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               DEPMOD="/bin/true" \
-               all
-endef
+       --with-xtlibdir="/usr/lib/iptables"
 
-define Build/Install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(KERNEL_MAKE_FLAGS) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               DEPMOD="/bin/true" \
-               install
-endef
+MAKE_FLAGS += \
+       DEPMOD="/bin/true"
+
+MAKE_INSTALL_FLAGS += \
+       DEPMOD="/bin/true"
 
 # 1: extension/module suffix used in package name
 # 2: extension/module display name used in package title/description