Revert "target,base-files: unify handling of procd-ujail"
authorPetr Štetiar <ynezz@true.cz>
Mon, 25 Nov 2024 21:23:54 +0000 (21:23 +0000)
committerPetr Štetiar <ynezz@true.cz>
Tue, 26 Nov 2024 05:07:33 +0000 (05:07 +0000)
This reverts commit ac640718aa0ceae55969bb9e7e45d00bb7bc228a as it
removes base-files package when KERNEL_NAMESPACES is deselected, as
base-files depends on procd-ujail which needs KERNEL_NAMESPACES.

Fixes: #17075
Link: https://github.com/openwrt/openwrt/pull/17081
Link: https://github.com/openwrt/openwrt/pull/17081
Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/target.mk
package/base-files/Makefile

index 1b32bf905d6d3c9030bcec5c087b58bc804d3dab..02ea68b15c81216fdeeeeca92aaf6736d155a728 100644 (file)
@@ -90,6 +90,11 @@ else
   endif
 endif
 
+# include ujail on systems with enough storage
+ifeq ($(filter small_flash,$(FEATURES)),)
+  DEFAULT_PACKAGES+=procd-ujail
+endif
+
 # Add device specific packages (here below to allow device type set from subtarget)
 DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))
 
index ff7891f18cb0c714df5b443f3200b44a8f34f97a..b90ee3a64ebca22bbe94228c10bc6e145b9ce844 100644 (file)
@@ -43,7 +43,7 @@ define Package/base-files
        +netifd +libc +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring \
        +NAND_SUPPORT:ubi-utils +fstools +fwtool \
        +SELINUX:procd-selinux +!SELINUX:procd +USE_SECCOMP:procd-seccomp \
-       +SELINUX:busybox-selinux +!SELINUX:busybox +!SMALL_FLASH:procd-ujail
+       +SELINUX:busybox-selinux +!SELINUX:busybox
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)~$(lastword $(subst -, ,$(REVISION)))