scsi: scsi: Export blacklist flags to sysfs
authorHannes Reinecke <hare@suse.de>
Mon, 2 Oct 2017 14:26:34 +0000 (16:26 +0200)
committerMartin K. Petersen <martin.petersen@oracle.com>
Tue, 17 Oct 2017 04:57:12 +0000 (00:57 -0400)
Each scsi device is scanned according to the found blacklist flags, but
this information is never presented to sysfs.  This makes it quite hard
to figure out if blacklisting worked as expected.  With this patch we're
exporting an additional attribute 'blacklist' containing the blacklist
flags for this device.

Signed-off-by: Hannes Reinecke <hare@suse.com>
Reviewed-by: Bart Van Assche <bart.vanassche@wdc.com>
Reviewed-by: Johannes Thumshirn <jthumshirn@suse.de>
Signed-off-by: Martin K. Petersen <martin.petersen@oracle.com>
drivers/scsi/Makefile
drivers/scsi/scsi_scan.c
drivers/scsi/scsi_sysfs.c

index 93dbe58c47c845ddbe7faf25e540401f67d6c0ab..c4298c7fe819f6c1add37b5a4c62589f01528583 100644 (file)
@@ -191,6 +191,14 @@ clean-files :=     53c700_d.h 53c700_u.h
 
 $(obj)/53c700.o $(MODVERDIR)/$(obj)/53c700.ver: $(obj)/53c700_d.h
 
+$(obj)/scsi_sysfs.o: $(obj)/scsi_devinfo_tbl.c
+
+quiet_cmd_bflags = GEN     $@
+       cmd_bflags = sed -n 's/.*BLIST_\([A-Z0-9_]*\) *.*/BLIST_FLAG_NAME(\1),/p' $< > $@
+
+$(obj)/scsi_devinfo_tbl.c: include/scsi/scsi_devinfo.h
+       $(call if_changed,bflags)
+
 # If you want to play with the firmware, uncomment
 # GENERATE_FIRMWARE := 1
 
index e7818afeda2bea560101fe023983050d0b3086b2..26edd61a5554adea59080b4edbe8a605846148e8 100644 (file)
@@ -984,6 +984,7 @@ static int scsi_add_lun(struct scsi_device *sdev, unsigned char *inq_result,
                scsi_attach_vpd(sdev);
 
        sdev->max_queue_depth = sdev->queue_depth;
+       sdev->sdev_bflags = *bflags;
 
        /*
         * Ok, the device is now all set up, we can
index cfc5e316f6cb98611aa4c234aae11987d55ba6ce..e7714547b310b18a1fc182b39eacf1236f988dc8 100644 (file)
@@ -20,6 +20,7 @@
 #include <scsi/scsi_dh.h>
 #include <scsi/scsi_transport.h>
 #include <scsi/scsi_driver.h>
+#include <scsi/scsi_devinfo.h>
 
 #include "scsi_priv.h"
 #include "scsi_logging.h"
@@ -966,6 +967,41 @@ sdev_show_wwid(struct device *dev, struct device_attribute *attr,
 }
 static DEVICE_ATTR(wwid, S_IRUGO, sdev_show_wwid, NULL);
 
+#define BLIST_FLAG_NAME(name) [ilog2(BLIST_##name)] = #name
+static const char *const sdev_bflags_name[] = {
+#include "scsi_devinfo_tbl.c"
+};
+#undef BLIST_FLAG_NAME
+
+static ssize_t
+sdev_show_blacklist(struct device *dev, struct device_attribute *attr,
+                   char *buf)
+{
+       struct scsi_device *sdev = to_scsi_device(dev);
+       int i;
+       ssize_t len = 0;
+
+       for (i = 0; i < sizeof(sdev->sdev_bflags) * BITS_PER_BYTE; i++) {
+               const char *name = NULL;
+
+               if (!(sdev->sdev_bflags & BIT(i)))
+                       continue;
+               if (i < ARRAY_SIZE(sdev_bflags_name) && sdev_bflags_name[i])
+                       name = sdev_bflags_name[i];
+
+               if (name)
+                       len += snprintf(buf + len, PAGE_SIZE - len,
+                                       "%s%s", len ? " " : "", name);
+               else
+                       len += snprintf(buf + len, PAGE_SIZE - len,
+                                       "%sINVALID_BIT(%d)", len ? " " : "", i);
+       }
+       if (len)
+               len += snprintf(buf + len, PAGE_SIZE - len, "\n");
+       return len;
+}
+static DEVICE_ATTR(blacklist, S_IRUGO, sdev_show_blacklist, NULL);
+
 #ifdef CONFIG_SCSI_DH
 static ssize_t
 sdev_show_dh_state(struct device *dev, struct device_attribute *attr,
@@ -1151,6 +1187,7 @@ static struct attribute *scsi_sdev_attrs[] = {
        &dev_attr_queue_depth.attr,
        &dev_attr_queue_type.attr,
        &dev_attr_wwid.attr,
+       &dev_attr_blacklist.attr,
 #ifdef CONFIG_SCSI_DH
        &dev_attr_dh_state.attr,
        &dev_attr_access_state.attr,