kernel: re-add missing symbols
authorKoen Vandeputte <koen.vandeputte@citymesh.com>
Tue, 11 Jun 2024 13:27:58 +0000 (15:27 +0200)
committerKoen Vandeputte <koen.vandeputte@citymesh.com>
Mon, 25 Nov 2024 17:34:36 +0000 (18:34 +0100)
a recent cleanup commit also removed our own custom symbols
added by various in-tree drivers.

re-add these symbols as the compiler will complain about
them otherwise on specific targets during kernel build:

MikroTik RB91x NAND driver support (MTD_NAND_RB91X) [N/m/y/?] (NEW) make[8]: *** [scripts/kconfig/Makefile:77: syncconfig] Error 1

Fixes: 2d00ed7caa ("kernel: trim outdated kernel config symbols")
Signed-off-by: Koen Vandeputte <koen.vandeputte@citymesh.com>
target/linux/generic/config-6.6

index 105dc0d344fa82c85b09482e051f35a282a60b08..cc0b295ecc1104fd603e3991ea5fb4202b501e58 100644 (file)
@@ -3732,6 +3732,10 @@ CONFIG_MTD_MAP_BANK_WIDTH_4=y
 # CONFIG_MTD_NAND_ORION is not set
 # CONFIG_MTD_NAND_PASEMI is not set
 # CONFIG_MTD_NAND_PLATFORM is not set
+# CONFIG_MTD_NAND_PXA3xx is not set
+# CONFIG_MTD_NAND_RB4XX is not set
+# CONFIG_MTD_NAND_RB750 is not set
+# CONFIG_MTD_NAND_RB91X is not set
 # CONFIG_MTD_NAND_RICOH is not set
 # CONFIG_MTD_NAND_S3C2410 is not set
 # CONFIG_MTD_NAND_SHARPSL is not set