passlib: Update to 1.7.4, rename source package
authorJeffery To <jeffery.to@gmail.com>
Tue, 6 Jun 2023 08:30:20 +0000 (16:30 +0800)
committerJeffery To <jeffery.to@gmail.com>
Wed, 7 Jun 2023 05:38:59 +0000 (13:38 +0800)
This renames the source package from passlib to python-passlib to match
other Python packages.

This also updates the package URL and list of dependencies.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
(cherry picked from commit 5b965e4d79afae179080a8bf3b370e650045fe05)

lang/python/passlib/Makefile [deleted file]
lang/python/python-passlib/Makefile [new file with mode: 0644]

diff --git a/lang/python/passlib/Makefile b/lang/python/passlib/Makefile
deleted file mode 100644 (file)
index 8080be9..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=passlib
-PKG_VERSION:=1.7.2
-PKG_RELEASE:=2
-PKG_LICENSE:=BSD-3-Clause
-
-PYPI_NAME:=$(PKG_NAME)
-PKG_HASH:=8d666cef936198bc2ab47ee9b0410c94adf2ba798e5a84bf220be079ae7ab6a8
-
-include ../pypi.mk
-include $(INCLUDE_DIR)/package.mk
-
-include ../python3-package.mk
-
-define Package/python3-passlib
-  SUBMENU:=Python
-  SECTION:=lang
-  CATEGORY:=Languages
-  TITLE:=Comprehensive password hashing framework
-  URL:=https://bitbucket.org/ecollins/passlib
-  DEPENDS:=+python3 +python3-dateutil
-endef
-
-define Package/python3-passlib/description
-Passlib is a password hashing library for Python 2 & 3, which provides
-cross-platform implementations of over 30 password hashing algorithms,
-as well as a framework for managing existing password hashes. It’s
-designed to be useful for a wide range of tasks, from verifying a hash
-found in /etc/shadow, to providing full-strength password hashing for
-multi-user applications.
-endef
-
-$(eval $(call Py3Package,python3-passlib))
-
-$(eval $(call BuildPackage,python3-passlib))
-$(eval $(call BuildPackage,python3-passlib-src))
diff --git a/lang/python/python-passlib/Makefile b/lang/python/python-passlib/Makefile
new file mode 100644 (file)
index 0000000..bcd6dc5
--- /dev/null
@@ -0,0 +1,40 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-passlib
+PKG_VERSION:=1.7.4
+PKG_RELEASE:=1
+
+PYPI_NAME:=passlib
+PKG_HASH:=defd50f72b65c5402ab2c573830a6978e5f202ad0d984793c8dde2c4152ebe04
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-passlib
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Comprehensive password hashing framework
+  URL:=https://passlib.readthedocs.io/
+  DEPENDS:=+python3
+endef
+
+define Package/python3-passlib/description
+Passlib is a password hashing library for Python 2 & 3, which provides
+cross-platform implementations of over 30 password hashing algorithms,
+as well as a framework for managing existing password hashes. It’s
+designed to be useful for a wide range of tasks, from verifying a hash
+found in /etc/shadow, to providing full-strength password hashing for
+multi-user applications.
+endef
+
+$(eval $(call Py3Package,python3-passlib))
+$(eval $(call BuildPackage,python3-passlib))
+$(eval $(call BuildPackage,python3-passlib-src))