dnsdist: switch from liblua to luajit
authorPeter van Dijk <peter.van.dijk@powerdns.com>
Mon, 20 Jun 2022 14:53:34 +0000 (16:53 +0200)
committerRosen Penev <rosenp@gmail.com>
Fri, 24 Jun 2022 18:30:21 +0000 (11:30 -0700)
luajit provides higher performance for requests handled in Lua hooks.
It also enables access to dnsdist functionality only exposed via FFI,
and allows configurations/hooks to call functions in any C library
without providing separate bindings.

Signed-off-by: Peter van Dijk <peter.van.dijk@powerdns.com>
(cherry picked from commit 283b269c7c0f164311b11d459953b1b34f6974cf)

net/dnsdist/Makefile

index 4d7da9ed3981fcfbd2b2b4ba554820e24b6321af..ed3fc73b37bba86a2c18a238473ae1ad40274d75 100644 (file)
@@ -115,7 +115,7 @@ define Package/dnsdist
          +libedit \
          +libstdcpp \
          +lmdb \
-         +liblua \
+         +luajit \
          +tinycdb
   URL:=https://dnsdist.org/
 endef
@@ -144,7 +144,7 @@ TARGET_CXX+=-std=c++17
 
 CONFIGURE_ARGS+= \
        --with-pic \
-       --with-lua=lua \
+       --with-lua=luajit \
        $(if $(CONFIG_DNSDIST_SODIUM),--enable-dnscrypt --with-libsodium,--disable-dnscrypt --without-libsodium) \
        $(if $(CONFIG_DNSDIST_DNSTAP),--enable-dnstap=yes,--enable-dnstap=no) \
        $(if $(CONFIG_DNSDIST_RE2),--with,--without)-re2 \