python-websockets: Update to 11.0.3, update list of dependencies
authorJeffery To <jeffery.to@gmail.com>
Tue, 29 Aug 2023 04:10:08 +0000 (12:10 +0800)
committerTianling Shen <cnsztl@gmail.com>
Fri, 8 Sep 2023 11:01:04 +0000 (19:01 +0800)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
(cherry picked from commit 98453732e2b7f74234776445844609f3b4dc70d0)

lang/python/python-websockets/Makefile

index 737ea39f4829ebb61d4dd40096b7141e6746990c..fac0d741b21d627e2305f2a250a0ade68e81e209 100644 (file)
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-websockets
-PKG_VERSION:=10.3
+PKG_VERSION:=11.0.3
 PKG_RELEASE:=1
 
 PYPI_NAME:=websockets
-PKG_HASH:=fc06cc8073c8e87072138ba1e431300e2d408f054b27047d047b549455066ff4
+PKG_HASH:=88fc51d9a26b10fc331be344f1781224a375b78488fc343620184e95a4b27016
 
 PKG_MAINTAINER:=Michal Vasilek <michal.vasilek@nic.cz>
 PKG_LICENSE:=BSD-3-Clause
@@ -26,18 +26,18 @@ define Package/python3-websockets
   SECTION:=lang
   CATEGORY:=Languages
   SUBMENU:=Python
-  TITLE:=Library for developing WebSocket servers and clients
-  URL:=https://websockets.readthedocs.io/
-  DEPENDS:=+python3-light +python3-asyncio +python3-ctypes +python3-email \
-    +python3-logging +python3-urllib
+  TITLE:=Implementation of the WebSocket Protocol
+  URL:=https://github.com/aaugustin/websockets
+  DEPENDS:=+python3
 endef
 
 define Package/python3-websockets/description
-  websockets is a library for building WebSocket servers and clients
-  in Python with a focus on correctness and simplicity.
+websockets is a library for building WebSocket servers and clients in
+Python with a focus on correctness, simplicity, robustness, and
+performance.
 
-  Built on top of asyncio, Python’s standard asynchronous I/O framework.
-  It provides an elegant coroutine-based API.
+Built on top of asyncio, Python's standard asynchronous I/O framework,
+the default implementation provides an elegant coroutine-based API.
 endef
 
 $(eval $(call Py3Package,python3-websockets))