logrotate: update to version 3.8.1
authorLuka Perkov <luka@openwrt.org>
Mon, 16 Jul 2012 21:52:03 +0000 (21:52 +0000)
committerLuka Perkov <luka@openwrt.org>
Mon, 16 Jul 2012 21:52:03 +0000 (21:52 +0000)
SVN-Revision: 32752

utils/logrotate/Makefile
utils/logrotate/patches/002-datehack.patch [deleted file]
utils/logrotate/patches/003-ignore_hidden.patch [deleted file]
utils/logrotate/patches/006-weekly.patch [deleted file]

index 8585c953654fa8bd8a94557dd86e3245ec343e03..9e62f56b46fd7fd5d1a2af2bfa6520182cf848f1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=logrotate
-PKG_VERSION:=3.7.8
+PKG_VERSION:=3.8.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:= \
-       http://ftp.de.debian.org/debian/pool/main/l/logrotate \
        http://ftp.debian.org/debian/pool/main/l/logrotate \
+       http://ftp.de.debian.org/debian/pool/main/l/logrotate \
        http://ftp.fr.debian.org/debian/pool/main/l/logrotate \
        http://ftp.us.debian.org/debian/pool/main/l/logrotate
-PKG_MD5SUM:=b3589bea6d8d5afc8a84134fddaae973
+PKG_MD5SUM:=bd2e20d8dc644291b08f9215397d28a5
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,10 +30,10 @@ define Package/logrotate
 endef
 
 define Package/logrotate/description
-       logrotate is designed to ease administration of systems that generate 
-       large numbers of log files. It allows auto-matic rotation, compression, 
-       removal and mailing of log files. Each log file may be handled daily, 
      weekly, monthly or when it grows too large.
+ logrotate is designed to ease administration of systems that generate large
+ numbers of log files. It allows auto-matic rotation, compression, removal and
+ mailing of log files. Each log file may be handled daily, weekly, monthly or
+ when it grows too large.
 endef
 
 define Package/logrotate/conffiles
diff --git a/utils/logrotate/patches/002-datehack.patch b/utils/logrotate/patches/002-datehack.patch
deleted file mode 100644 (file)
index ffb6c8d..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/logrotate.c
-+++ b/logrotate.c
-@@ -1505,7 +1505,7 @@ static int readState(char *stateFilename
-       }
-       /* Hack to hide earlier bug */
--      if ((year != 1900) && (year < 1996 || year > 2100)) {
-+      if ((year != 1900) && (year < 1970 || year > 2100)) {
-           message(MESS_ERROR,
-                   "bad year %d for file %s in state file %s\n", year,
-                   argv[0], stateFilename);
diff --git a/utils/logrotate/patches/003-ignore_hidden.patch b/utils/logrotate/patches/003-ignore_hidden.patch
deleted file mode 100644 (file)
index 7ca5392..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/config.c
-+++ b/config.c
-@@ -160,8 +160,9 @@ static int checkFile(const char *fname)
-       int i;
-       char pattern[PATH_MAX];
--      /* Check if fname is '.' or '..'; if so, return false */
--      if (fname[0] == '.' && (!fname[1] || (fname[1] == '.' && !fname[2])))
-+      /* Don't include 'hidden' files either; this breaks Gentoo 
-+         portage config file management http://bugs.gentoo.org/87683 */
-+      if (fname[0] == '.')
-               return 0;
-       /* Check if fname is ending in a taboo-extension; if so, return false */
diff --git a/utils/logrotate/patches/006-weekly.patch b/utils/logrotate/patches/006-weekly.patch
deleted file mode 100644 (file)
index a861604..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/logrotate.c
-+++ b/logrotate.c
-@@ -567,9 +567,14 @@ int findNeedRotating(struct logInfo *log
-           /* rotate if:
-              1) the current weekday is before the weekday of the
-              last rotation
-+             1) the day of the week is the same as the day of the week of
-+             the previous rotation but not the same day of the year
-+             this will rotate it on the same day every week, but not
-+             twice a day.
-              2) more then a week has passed since the last
-              rotation */
--          state->doRotate = ((now.tm_wday < state->lastRotated.tm_wday)
-+          state->doRotate = ((now.tm_wday == state->lastRotated.tm_wday
-+                                   && now.tm_yday != state->lastRotated.tm_yday)
-                              ||
-                              ((mktime(&now) -
-                                mktime(&state->lastRotated)) >