ramips: mt7621: enable lzma-loader for Amped Wireless ALLY
authorJonathan Sturges <jsturges@redhat.com>
Fri, 27 Dec 2024 02:47:40 +0000 (21:47 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 1 Jan 2025 22:14:31 +0000 (23:14 +0100)
Switch to using loader-kernel to accommodate
larger image sizes that are problematic for
many mt7621 uboots.

Signed-off-by: Jonathan Sturges <jsturges@redhat.com>
Link: https://github.com/openwrt/openwrt/pull/17389
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit f8a8a2c5c7ff1efe289d846a890d3361757c231f)

target/linux/ramips/image/mt7621.mk

index eb7dacefefb7936df387308b490e637e828e7c46..9c6efb8f1c7bb7d6a173725860bdcc589d55acaa 100644 (file)
@@ -294,11 +294,11 @@ TARGET_DEVICES += alfa-network_quad-e4g
 
 define Device/ampedwireless_ally_common
   $(Device/nand)
+  $(Device/uimage-lzma-loader)
   DEVICE_VENDOR := Amped Wireless
   DEVICE_PACKAGES := kmod-mt7615-firmware
   IMAGE_SIZE := 32768k
-  KERNEL_INITRAMFS := $(KERNEL_DTB) | uImage lzma -n 'flashable-initramfs' |\
-       edimax-header -s CSYS -m RN68 -f 0x001c0000 -S 0x01100000
+  KERNEL_INITRAMFS := $$(KERNEL) | edimax-header -s CSYS -m RN68 -f 0x001c0000 -S 0x01100000
 endef
 
 define Device/ampedwireless_ally-r1900k