spoofer: Fix compilation without deprecated OpenSSL APIs
authorRosen Penev <rosenp@gmail.com>
Mon, 7 Jan 2019 05:05:37 +0000 (21:05 -0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 7 Jan 2019 05:06:30 +0000 (21:06 -0800)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/spoofer/Makefile
net/spoofer/patches/010-openssl-deprecated.patch [new file with mode: 0644]

index c2dc44b290397fac100b55748a0b9d26f45343be..1c46ac6a9862f4bd68a0d3477b464b35120e2c00 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=spoofer
 PKG_VERSION:=1.4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.caida.org/projects/spoofer/downloads
diff --git a/net/spoofer/patches/010-openssl-deprecated.patch b/net/spoofer/patches/010-openssl-deprecated.patch
new file mode 100644 (file)
index 0000000..1e3efc8
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/prober/spoofer-prober.cc
++++ b/prober/spoofer-prober.cc
+@@ -2135,8 +2135,10 @@ int main(int argc, char **argv) {
+ #endif
+ #ifdef HAVE_LIBSSL
+     if (enableTLS) {
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+       SSL_load_error_strings();
+       SSL_library_init();
++#endif
+       ssl_ctx = SSL_CTX_new(SSLv23_client_method());
+       if (!ssl_ctx) {
+           ssl_err("SSL_CTX_new() failed");