modemmanager: add error message notifications to proto handler
authorNicholas Smith <nicholas.smith@telcoantennas.com.au>
Fri, 10 Jul 2020 10:25:42 +0000 (20:25 +1000)
committerNicholas Smith <nicholas.smith@telcoantennas.com.au>
Fri, 10 Jul 2020 10:28:31 +0000 (20:28 +1000)
Signed-off-by: Nicholas Smith <nicholas.smith@telcoantennas.com.au>
net/modemmanager/Makefile
net/modemmanager/files/modemmanager.proto

index 5bd64bde8a3c0690f429d3377545f8f6ea5c238a..9f1d33317170091f296e3fa6c42bf476e67923f9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=modemmanager
 PKG_VERSION:=1.14.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=ModemManager-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.freedesktop.org/software/ModemManager
index 2e95d1e57effa06d42e2de125f504d0f1b5228de..07147b1f366fceed95b306ec9d6fb71a6ed363fa 100755 (executable)
@@ -327,6 +327,7 @@ modemmanager_disconnected_method_common() {
        local interface="$1"
 
        echo "running disconnection (common)"
+       proto_notify_error "${interface}" MM_DISCONNECT_IN_PROGRESS
 
        proto_init_update "*" 0
        proto_send_update "${interface}"
@@ -393,9 +394,11 @@ proto_modemmanager_setup() {
 
        # setup connect args; APN mandatory (even if it may be empty)
        echo "starting connection with apn '${apn}'..."
+       proto_notify_error "${interface}" MM_CONNECT_IN_PROGRESS
+
        connectargs="apn=${apn}${iptype:+,ip-type=${iptype}}${cliauth:+,allowed-auth=${cliauth}}${username:+,user=${username}}${password:+,password=${password}}${pincode:+,pin=${pincode}}"
        mmcli --modem="${device}" --timeout 120 --simple-connect="${connectargs}" || {
-               proto_notify_error "${interface}" CONNECT_FAILED
+               proto_notify_error "${interface}" MM_CONNECT_FAILED
                proto_block_restart "${interface}"
                return 1
        }
@@ -497,6 +500,7 @@ proto_modemmanager_teardown() {
        json_get_vars device lowpower iptype
 
        echo "stopping network"
+       proto_notify_error "${interface}" MM_TEARDOWN_IN_PROGRESS
 
        # load connected bearer information, just the first one should be ok
        modemstatus=$(mmcli --modem="${device}" --output-keyvalue)
@@ -525,6 +529,7 @@ proto_modemmanager_teardown() {
 
        # disable
        mmcli --modem="${device}" --disable
+       proto_notify_error "${interface}" MM_MODEM_DISABLED
 
        # low power, only if requested
        [ "${lowpower:-0}" -lt 1 ] ||