rules.mk: Update ccache's compiler check.
authorMarkus Gothe <markus.gothe@genexis.eu>
Tue, 7 Feb 2023 21:00:33 +0000 (22:00 +0100)
committerJohn Crispin <john@phrozen.org>
Thu, 12 Dec 2024 10:01:56 +0000 (11:01 +0100)
Update the compiler check for ccache so we don't
end up with the wrong binaries. Right now the
compiler check will not be able to correctly
distinguish the compiler used for build
ARMv8 binaries from the one used to build
ARMv7 binaries.

Signed-off-by: Markus Gothe <markus.gothe@genexis.eu>
Link: https://github.com/openwrt/openwrt/pull/16290
Signed-off-by: John Crispin <john@phrozen.org>
rules.mk

index 9db7c72fa492ebd7539ebe1f3198c2ee955e86bb..16d6020e1a0efe5fbd1587a0e5123de1559c82f7 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -346,7 +346,7 @@ ifneq ($(CONFIG_CCACHE),)
   export CCACHE_NOCOMPRESS:=true
   export CCACHE_BASEDIR:=$(TOPDIR)
   export CCACHE_DIR:=$(if $(call qstrip,$(CONFIG_CCACHE_DIR)),$(call qstrip,$(CONFIG_CCACHE_DIR)),$(TOPDIR)/.ccache)
-  export CCACHE_COMPILERCHECK:=%compiler% -dumpmachine; %compiler% -dumpversion
+  export CCACHE_COMPILERCHECK:=%compiler% -v -c
 endif
 
 TARGET_CONFIGURE_OPTS = \