crun: update to version 1.2
authorOskari Rauta <oskari.rauta@gmail.com>
Thu, 4 Nov 2021 23:41:20 +0000 (01:41 +0200)
committerNick Hainke <vincent@systemli.org>
Fri, 5 Nov 2021 06:21:36 +0000 (07:21 +0100)
release notes:

0.20.1
 - container: ignore error when resetting the SELinux label for the keyring.

0.21
 - when compiled with krun, automatically use it if the current executable file is called "krun"
 - cgroup: lookup pids controller as well when the memory controller is not available
 - status: add fields for owner and created timestamp
 - honor memory swappiness set to 0

1.0
 - Fix symlink target mangling for tmpcopyup targets.
 - Makefile.am: fix link error when using directly libcrun.
 - cgroup: add support for setting memory.use_hierarchy on cgroup v1.
 - linux: treat pidfd_open failures EINVAL as ESRCH.
 - cgroup: chown the current container cgroup to root in the container.

1.1
 - utils: retry openat2 on EAGAIN. If the openat2 syscall is interrupted, try again.
 - criu: fix save of external descriptors. Now restored containers attach correctly their standard streams.
 - criu: Add support for external PID namespace.
 - container: Set primary process to 1 via LISTEN_PID by default if user configuration is missing.
 - exec: refuse to exec in a paused container/cgroup.
 - cgroup: use cgroup.kill when available. It is faster to kill a container through its cgroup as there is no need to recurse over the cgroup pids and terminate each one of them.

1.2
 - criu: add support for external ipc, uts and time namespaces.
 - exec: fix regression in 1.1 where containers are being wrongly reported as paused.

Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
utils/crun/Makefile

index 3d47bd504a0ef73c95385c07fee81e6770ad7428..50314888f9077adf43cebf0b5a59ab159d77d3db 100644 (file)
@@ -1,14 +1,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=crun
-PKG_VERSION:=0.20
+PKG_VERSION:=1.2
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/containers/crun.git
-PKG_SOURCE_DATE:=2021-06-07
-PKG_SOURCE_VERSION:=8d6a8b5ab80461cfed19f020a36584af13c32038
-PKG_MIRROR_HASH:=9ca1f0e530b33ce8820bd03329eb6731c5050d6e7f35bd2463d9a81cc00382e0
+PKG_SOURCE_DATE:=2021-11-04
+PKG_SOURCE_VERSION:=e2ddb7c503b78b5446824b7ac40293fb461344ee
+PKG_MIRROR_HASH:=173189bc7db6fa8f30ae6e7ad19281baba0935c54fc4e06a684767b5267321fe
 
 PKG_BUILD_DEPENDS:=argp-standalone
 PKG_BUILD_PARALLEL:=1