libxerces-c: fix pkgconfig paths
authorRosen Penev <rosenp@gmail.com>
Tue, 14 Jul 2020 04:53:54 +0000 (21:53 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 14 Jul 2020 21:09:47 +0000 (14:09 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libxerces-c/Makefile

index 0f19cc577a32f7908560b5e17539d1a81b30f982..bd9a54e10761e5122d677fa0f186f646f07131b6 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xerces-c
 PKG_VERSION:=3.2.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@APACHE/xerces/c/3/sources
@@ -74,6 +74,8 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/cmake/XercesC/* $(1)/usr/lib/cmake/XercesC
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/xerces-c.pc $(1)/usr/lib/pkgconfig/xerces-c.pc
+       $(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/xerces-c.pc
+       $(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/xerces-c.pc
 endef
 
 define Package/libxerces-c/install