libcap: Fix compilation with uClibc-ng
authorRosen Penev <rosenp@gmail.com>
Sat, 11 Jan 2020 02:36:33 +0000 (18:36 -0800)
committerRosen Penev <rosenp@gmail.com>
Sat, 11 Jan 2020 02:37:18 +0000 (18:37 -0800)
The test does not compile with --static.

As this does not touch binaries, not bumping the package release.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libcap/patches/300-uclibc-ng.patch [new file with mode: 0644]

diff --git a/libs/libcap/patches/300-uclibc-ng.patch b/libs/libcap/patches/300-uclibc-ng.patch
new file mode 100644 (file)
index 0000000..616d272
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -32,7 +32,7 @@ run_libcap_psx_test: libcap_psx_test
+       ./libcap_psx_test
+ libcap_psx_test: libcap_psx_test.c $(DEPS)
+-      $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create --static
++      $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create
+ clean:
+       rm -f psx_test psx_test_wrap libcap_psx_test