sqm-scripts: Add required new depends for luci-app-sqm
authorZachary Cook <zachcook1991@gmail.com>
Mon, 4 Nov 2019 16:43:59 +0000 (11:43 -0500)
committerZachary Cook <zachcook1991@gmail.com>
Mon, 4 Nov 2019 17:27:36 +0000 (12:27 -0500)
The new luci-compat package is required to be able to run luci-app-sqm, see:
https://github.com/openwrt/luci/commit/d5dff8f9a5ca85d197cbb6037f95053bc55941e5

Signed-off-by: Zachary Cook <zachcook1991@gmail.com>
net/sqm-scripts/Makefile

index 654a61f4c2681a335730646bc8d76c6c040e046c..cd21b0af84bcb9a43a01839f97529708486e4271 100644 (file)
@@ -10,11 +10,11 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=sqm-scripts
 PKG_SOURCE_VERSION:=ab763cba8b1516b3afa99760e0ca884f8b8d93b8
 PKG_VERSION:=1.4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=GPLv2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_RELEASE).tar.xz
-PKG_MIRROR_HASH:=00bc93f667ad417d4ba9bea4a01d87e3c670a294f61de13348a0f71e7700241f
+PKG_MIRROR_HASH:=6e8ce29ba398c14fe679ea95fe03c785d7b5357d515b988360b4cc8be68b7e59
 PKG_SOURCE_URL:=https://github.com/tohojo/sqm-scripts.git
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_RELEASE)
@@ -51,7 +51,7 @@ define Package/luci-app-sqm
   TITLE:=SQM Scripts - LuCI interface
   MAINTAINER:=Toke Høiland-Jørgensen <toke@toke.dk>
   PKGARCH:=all
-  DEPENDS:= +lua +luci-base +sqm-scripts
+  DEPENDS:= +lua +luci-base +luci-compat +sqm-scripts
   SUBMENU:=3. Applications
 endef