transmission: update to version 4.0.6
authorKarol Kolacinski <kolacinskikarol@live.com>
Sat, 6 Jul 2024 16:12:01 +0000 (18:12 +0200)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Sat, 20 Jul 2024 12:51:05 +0000 (14:51 +0200)
Release notes:
https://github.com/transmission/transmission/releases/tag/4.0.6

Remove temporary patch included in 4.0.6 release.

Signed-off-by: Karol Kolacinski <kolacinskikarol@live.com>
(cherry picked from commit c32139757cf13b78a114fbd900aadba8ae1b94b7)

net/transmission/Makefile
net/transmission/patches/010-temp-mbedtls3-compile.patch [deleted file]

index d688d3691a3ff7da0a8f32e7fe80ddc7fc18b411..d6b297b84928ceaa9e8bed4f3f25fbae6ecfe7e6 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
-PKG_VERSION:=4.0.5
-PKG_RELEASE:=2
+PKG_VERSION:=4.0.6
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/transmission/transmission/releases/download/$(PKG_VERSION)/
-PKG_HASH:=fd68ff114a479200043c30c7e69dba4c1932f7af36ca4c5b5d2edcb5866e6357
+PKG_HASH:=2a38fe6d8a23991680b691c277a335f8875bdeca2b97c6b26b598bc9c7b0c45f
 
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=GPL-2.0-or-later
diff --git a/net/transmission/patches/010-temp-mbedtls3-compile.patch b/net/transmission/patches/010-temp-mbedtls3-compile.patch
deleted file mode 100644 (file)
index f3c473b..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-From da7d6fe0e1b162eac6cc048153ff7f201975b6c4 Mon Sep 17 00:00:00 2001
-From: Seo Suchan <tjtncks@gmail.com>
-Date: Thu, 2 May 2024 03:34:12 +0900
-Subject: [PATCH] fix compile with mbedtls 3.x
-
-Signed-off-by: Seo Suchan <tjtncks@gmail.com>
----
- libtransmission/crypto-utils-mbedtls.cc | 14 +++++++-------
- 1 file changed, 7 insertions(+), 7 deletions(-)
-
---- a/libtransmission/crypto-utils-mbedtls.cc
-+++ b/libtransmission/crypto-utils-mbedtls.cc
-@@ -117,7 +117,7 @@ public:
-     {
-         mbedtls_sha1_init(&handle_);
--#if MBEDTLS_VERSION_NUMBER >= 0x02070000
-+#if MBEDTLS_VERSION_NUMBER < 0x03000000 && MBEDTLS_VERSION_NUMBER >= 0x02070000
-         mbedtls_sha1_starts_ret(&handle_);
- #else
-         mbedtls_sha1_starts(&handle_);
-@@ -128,7 +128,7 @@ public:
-     {
-         if (data_length > 0U)
-         {
--#if MBEDTLS_VERSION_NUMBER >= 0x02070000
-+#if MBEDTLS_VERSION_NUMBER < 0x03000000 && MBEDTLS_VERSION_NUMBER >= 0x02070000
-             mbedtls_sha1_update_ret(&handle_, static_cast<unsigned char const*>(data), data_length);
- #else
-             mbedtls_sha1_update(&handle_, static_cast<unsigned char const*>(data), data_length);
-@@ -140,7 +140,7 @@ public:
-     {
-         auto digest = tr_sha1_digest_t{};
-         auto* const digest_as_uchar = reinterpret_cast<unsigned char*>(std::data(digest));
--#if MBEDTLS_VERSION_NUMBER >= 0x02070000
-+#if MBEDTLS_VERSION_NUMBER < 0x03000000 && MBEDTLS_VERSION_NUMBER >= 0x02070000
-         mbedtls_sha1_finish_ret(&handle_, digest_as_uchar);
- #else
-         mbedtls_sha1_finish(&handle_, digest_as_uchar);
-@@ -168,10 +168,10 @@ public:
-     {
-         mbedtls_sha256_init(&handle_);
--#if MBEDTLS_VERSION_NUMBER >= 0x02070000
-+#if MBEDTLS_VERSION_NUMBER < 0x03000000 && MBEDTLS_VERSION_NUMBER >= 0x02070000
-         mbedtls_sha256_starts_ret(&handle_, 0);
- #else
--        mbedtls_sha256_starts(&handle_);
-+        mbedtls_sha256_starts(&handle_, 0);
- #endif
-     }
-@@ -179,7 +179,7 @@ public:
-     {
-         if (data_length > 0U)
-         {
--#if MBEDTLS_VERSION_NUMBER >= 0x02070000
-+#if MBEDTLS_VERSION_NUMBER < 0x03000000 && MBEDTLS_VERSION_NUMBER >= 0x02070000
-             mbedtls_sha256_update_ret(&handle_, static_cast<unsigned char const*>(data), data_length);
- #else
-             mbedtls_sha256_update(&handle_, static_cast<unsigned char const*>(data), data_length);
-@@ -191,7 +191,7 @@ public:
-     {
-         auto digest = tr_sha256_digest_t{};
-         auto* const digest_as_uchar = reinterpret_cast<unsigned char*>(std::data(digest));
--#if MBEDTLS_VERSION_NUMBER >= 0x02070000
-+#if MBEDTLS_VERSION_NUMBER < 0x03000000 && MBEDTLS_VERSION_NUMBER >= 0x02070000
-         mbedtls_sha256_finish_ret(&handle_, digest_as_uchar);
- #else
-         mbedtls_sha256_finish(&handle_, digest_as_uchar);