mini_snmpd: Add sysDescr option.
authorRobert von Könemann <lordtaifleh@gmail.com>
Sat, 9 May 2020 12:35:36 +0000 (14:35 +0200)
committerRobert von Könemann <lordtaifleh@gmail.com>
Thu, 14 May 2020 19:18:48 +0000 (21:18 +0200)
Some monitoring tools will run into errors when sysDescr field is empty. This was the case for cacti 1.2.8 that i'm using to monitor my network. Ideally the sysDescr field would contain some information from the overview of luci, e.g. the Model, Firmware and Kernel-Version fields, but i am stranger to OpenWRT, so I'm unable to do that.

Signed-off-by: Robert von Könemann <lordtaifleh@gmail.com>
net/mini_snmpd/Makefile
net/mini_snmpd/files/mini_snmpd.config
net/mini_snmpd/files/mini_snmpd.init

index a40ba7e959ae6424708ea885d6ca214b4e0230a4..69f33b7796744664c1d9b991d5a105aa893014b1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mini_snmpd
 PKG_VERSION:=1.4-rc1
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_MAINTAINER:=Marcin Jurkowski <marcin1j@gmail.com>
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING
index c06f7b19018aa4ed5cd1d7e222083063588fcfab..e00685ea91483aadaa9036a84c9c58576057ec6c 100644 (file)
@@ -8,6 +8,7 @@ config mini_snmpd 'default'
        # Turn on community authentication (snmp agent must use community name)
        option auth 0
        option community 'public'
+       option description 'OpenWRT'
        option contact 'OpenWRT router <openwrt@openwrt.org>'
        option location 'Undisclosed'
        # to listen on all interfaces you need to set option listen_interface ''
index 96dc5ab9e839321dce8a52184c67727f3ace3d71..d0b1e204e5ed641b66c211a0b56f7ce7f221eaeb 100644 (file)
@@ -36,6 +36,7 @@ mini_snmpd_validation="enabled:bool:0 \
                auth:bool:1 \
                community:rangelength(1,32):public \
                contact:maxlength(255) \
+               description:maxlength(255) \
                location:maxlength(255) \
                listen_interface:uciname \
                udp_port:port \
@@ -212,6 +213,7 @@ start_instance() {
        append_arg "-c" "$community"
        append_arg "-L" "$location"
        append_arg "-C" "$contact"
+       append_arg "-D" "$description"
        append_arg "-p" $udp_port
        append_arg "-P" $tcp_port
        append_arg "-V" "$vendor_oid"