vfio: platform: reset: fix up include directives to remove ccflags-y
authorMasahiro Yamada <yamada.masahiro@socionext.com>
Wed, 30 Jan 2019 02:52:31 +0000 (11:52 +0900)
committerAlex Williamson <alex.williamson@redhat.com>
Tue, 5 Feb 2019 20:29:30 +0000 (13:29 -0700)
For the include directive with double-quotes "", the preprocessor
searches the header in the relative path to the current file.

Fix them up, and remove the header search path option.

Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
Acked-by: Eric Auger <eric.auger@redhat.com>
Signed-off-by: Alex Williamson <alex.williamson@redhat.com>
drivers/vfio/platform/reset/Makefile
drivers/vfio/platform/reset/vfio_platform_amdxgbe.c
drivers/vfio/platform/reset/vfio_platform_bcmflexrm.c
drivers/vfio/platform/reset/vfio_platform_calxedaxgmac.c

index 57abd4f0ac5b21fe691a903c0f4d73b933816094..7294c5ea122e9d8daa36027d6fb73c72add68ac4 100644 (file)
@@ -2,8 +2,6 @@
 vfio-platform-calxedaxgmac-y := vfio_platform_calxedaxgmac.o
 vfio-platform-amdxgbe-y := vfio_platform_amdxgbe.o
 
-ccflags-y += -Idrivers/vfio/platform
-
 obj-$(CONFIG_VFIO_PLATFORM_CALXEDAXGMAC_RESET) += vfio-platform-calxedaxgmac.o
 obj-$(CONFIG_VFIO_PLATFORM_AMDXGBE_RESET) += vfio-platform-amdxgbe.o
 obj-$(CONFIG_VFIO_PLATFORM_BCMFLEXRM_RESET) += vfio_platform_bcmflexrm.o
index bcd419cfd79cad3d0d60fecab2d8c53d9f8af5c1..3ddb2704221d9182969b9153392161074fa99ea4 100644 (file)
@@ -25,7 +25,7 @@
 #include <uapi/linux/mdio.h>
 #include <linux/delay.h>
 
-#include "vfio_platform_private.h"
+#include "../vfio_platform_private.h"
 
 #define DMA_MR                 0x3000
 #define MAC_VR                 0x0110
index d45c3be7119866d96dcfc750f97e6f386b286ac0..16165a62b86de01d7a11d6daa45b8ea6cb3afce5 100644 (file)
@@ -23,7 +23,7 @@
 #include <linux/kernel.h>
 #include <linux/module.h>
 
-#include "vfio_platform_private.h"
+#include "../vfio_platform_private.h"
 
 /* FlexRM configuration */
 #define RING_REGS_SIZE                                 0x10000
index 49e5df6e8f29122e2c81f6757006f1974796ea67..e0356de5df5406a44838244b97393143b0f2c9e0 100644 (file)
@@ -24,7 +24,7 @@
 #include <linux/init.h>
 #include <linux/io.h>
 
-#include "vfio_platform_private.h"
+#include "../vfio_platform_private.h"
 
 #define DRIVER_VERSION  "0.1"
 #define DRIVER_AUTHOR   "Eric Auger <eric.auger@linaro.org>"