projects
/
feed
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
66caa56
)
zstd: remove lto and as-needed flags
author
Rosen Penev
<rosenp@gmail.com>
Sun, 26 Apr 2020 02:50:05 +0000
(19:50 -0700)
committer
Rosen Penev
<rosenp@gmail.com>
Sun, 26 Apr 2020 23:21:55 +0000
(16:21 -0700)
The former can be implemented as a meson argument.
The latter is already default.
No compiled difference, therefore no PKG_RELEASE bump.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/zstd/Makefile
patch
|
blob
|
history
diff --git
a/utils/zstd/Makefile
b/utils/zstd/Makefile
index e45daf94deaf0d4f0749749de30a4e6e6e4fa48e..f968f6b4b0888099b109c79a40b45cf767808ab6 100644
(file)
--- a/
utils/zstd/Makefile
+++ b/
utils/zstd/Makefile
@@
-74,10
+74,8
@@
MESON_ARGS += \
-Dbin_control=false \
-Dzlib=disabled \
-Dlzma=disabled \
- -Dlz4=disabled
-
-TARGET_CFLAGS += -flto
-TARGET_LDFLAGS += -Wl,--as-needed
+ -Dlz4=disabled \
+ -Db_lto=true
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include