projects
/
openwrt
/
staging
/
svanheule.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
deb0f28
)
mediatek: append metadata to factory-uboot.bin for WSR devices
author
INAGAKI Hiroshi
<musashino.open@gmail.com>
Sat, 28 Dec 2024 10:07:09 +0000
(19:07 +0900)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 4 Jan 2025 18:25:34 +0000
(19:25 +0100)
Append metadata to factory-uboot.bin image to pass the image verification
on sysupgrade.
Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Link:
https://github.com/openwrt/openwrt/pull/17408
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit
a06a2ef89db03fac2cbd950304e5b507da9deb1e
)
target/linux/mediatek/image/mt7622.mk
patch
|
blob
|
history
diff --git
a/target/linux/mediatek/image/mt7622.mk
b/target/linux/mediatek/image/mt7622.mk
index 9f5fdc868885217031e3702ce2ab4ddd90b5924f..faf1b20e4ac47a1da9ea628b92e86d6145e1a286 100644
(file)
--- a/
target/linux/mediatek/image/mt7622.mk
+++ b/
target/linux/mediatek/image/mt7622.mk
@@
-123,7
+123,7
@@
define Device/buffalo_wsr
buffalo-enc $$(DEVICE_MODEL) $$(BUFFALO_TAG_VERSION) -l | \
buffalo-tag-dhp $$(DEVICE_MODEL) JP JP | buffalo-enc-tag -l | buffalo-dhp-image
IMAGE/factory-uboot.bin := append-ubi | \
- buffalo-trx $$$$(BUFFALO_TRX_MAGIC) $$$$@ $(KDIR)/ubi_mark
+ buffalo-trx $$$$(BUFFALO_TRX_MAGIC) $$$$@ $(KDIR)/ubi_mark
| append-metadata
IMAGE/sysupgrade.bin := \
buffalo-trx $$$$(BUFFALO_TRX_MAGIC) $(KDIR)/tmp/$$(DEVICE_NAME).null | \
sysupgrade-tar kernel=$$$$@ | append-metadata