tcsh: update to 6.22.04
authorRosen Penev <rosenp@gmail.com>
Wed, 2 Jun 2021 01:28:43 +0000 (18:28 -0700)
committerNuno Goncalves <nunojpg@gmail.com>
Fri, 4 Jun 2021 10:19:57 +0000 (12:19 +0200)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/tcsh/Makefile
utils/tcsh/patches/010-wint.patch

index f2a8ceb05aa4355efe422cbccf00cfb289761305..4f41e31ec2cf5c3d0c032495c3dd0781bfb4a5c4 100644 (file)
@@ -7,8 +7,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tcsh
-PKG_VERSION:=6.22.03
-PKG_RELEASE:=1
+PKG_VERSION:=6.22.04
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:= \
        https://astron.com/pub/tcsh/old \
        https://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh \
        https://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/old
-PKG_HASH:=be2cfd653d2a0c7f506d2dd14c12324ba749bd484037be6df44a3973f52262b7
+PKG_HASH:=eb16356243218c32f39e07258d72bf8b21e62ce94bb0e8a95e318b151397e231
 
 PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
 PKG_LICENSE:=BSD-3-Clause
index 2f6fc94d2d97022c07293dd6a1397302f57e4c84..18c373d0217b6d89fff720c421c55baa9ffba747 100644 (file)
@@ -3,7 +3,7 @@
 @@ -668,9 +668,9 @@ int
  GetCmdChar(Char ch)
  {
- #ifndef WINNT_NATIVE // We use more than 256 for various extended keys 
+ #ifndef WINNT_NATIVE // We use more than 256 for various extended keys
 -    wint_t c = ch & CHAR;
 +    Char c = ch & CHAR;
  #else